Hi, Hans,

Thanks for the link. I figured out the problem.  It turned out the data type
nexus was registered twice in the datatypes_conf.xml and the second one was
not using the right type.

THanks,
Luobin

On Fri, Jul 22, 2011 at 1:19 AM, Hans-Rudolf Hotz <h...@fmi.ch> wrote:

> Hi Luobin
>
> It is difficult to guess without seeing your code.
>
> So, assuming you followed the steps described in the wiki (
> http://wiki.g2.bx.psu.edu/**Admin/Datatypes/Adding%**20Datatypes<http://wiki.g2.bx.psu.edu/Admin/Datatypes/Adding%20Datatypes>),
> I guess you just made a typo somewhere (since this has happen to me several
> times when adding a new datatype). Have you double checked your tool
> definition file?
>
>
> Regards, Hans
>
>
>
> On 07/22/2011 07:52 AM, Luobin Yang wrote:
>
>> Hi,
>>
>> I created an XML file for a tool. This tool has an Nexus input. When I
>> click
>> the input field of the web interface for this tool, it shows all kinds of
>> data that I can select. How do I restrict the list to show only data in
>> nexus format? I added a line in the registration part and the sniffer part
>> of the datatypes_conf.xml and I also created a class called Nexus which
>> inherits the class galaxy.datatypes.Sequence, but this doesn't solve the
>> problem.
>>
>> Thanks,
>> Luobin
>>
>>
>>
>>
>> ______________________________**_____________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>
>>   http://lists.bx.psu.edu/
>>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to