Hello all,
I get troubles installing Picard.
In short is there a dedicated link with precise instructions on how to
install it on Galaxy?
I spent hours trying to install it and if I made a subtle step forward in
the installation, I am still stuck with exceptions when trying to run any
picard tool.

My first problem was to have a link to a built-in reference genome. I
finally fixed it. I explain my solution here for interested persons.
(1) create the 'dict' file from your reference fasta file by using the
following picard tool:
java -jar CreateSequenceDictionary.jar -R=<ref-genome.fa>
-O=<ref-genome.dict>

(2) modify the picard.loc index file to point to the correct location

(3) -- the step that took me hours to find --  modify the all-fasta.loc file
to point to the correct location.

Second -and still unsolved- problem: When i try to run a picard tool, I get
the following exception:

 File "/home/hg/Galaxy/galaxy-dist/tools/picard/picard_wrapper.py", line 40
    class PicardBase():
                     ^
SyntaxError: invalid syntax

I downloaded the last release of picard (picard-tools-1.48) and put all the
jars file in tool-data/shared/jars/
permission of the files are : -rw-r--r-- 1 apache      adm

I suspect that galaxy can't find the jars file (i get the same error if I
remove them from that location). Am I missing something?
Should I precise something about the classpath in galaxY?

Thank you for your help,
Colin
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to