Clare;

> I am trying to use install_data_s3 (data_fabfile.py) to get data from
> the cloudbiolinux bucket into a virtualbox VM, as per the instructions
> at usegalaxy.org/vm .
> 
> When I ran
> fab -f data_fabfile.py -H localhost
> install_data_s3:config/galaxy_default_biodata.yaml
> the first time, it worked.
> 
> But when I try running it a second time, it dies with
> [localhost] run: echo 'index   phix
> /mnt/galaxyIndices/genomes/phiX174/phix/seq/phix.fa >>
> sam_fa_indices.loc
> [localhost] out: /bin/bash: sam_fa_indices.loc: Permission denied

The fabric script is running standard shell commands, so all of the 
normal unix permissions will apply. As you mention, if the
permissions to /mnt/galaxyTools/galaxy-central/tool-data/sam_fa_indices.loc
do not allow access to galaxyadmin you'll need to adjust that from
the commandline.

Reading the instructions, the 'galaxyadmin' and 'galaxy' user
suggestions are a bit confusing. My suggestion it to run the
install_data_s3 command as the 'galaxy' user, and do: 'sudo chmod -R
galaxy /directory/name' on any directories with permission issues.
Since you later run the server as 'galaxy', this will ensure that
user has proper permissions.

Hope this helps,
Brad
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to