I have performed a new install of Galaxy for development and deployment 
purposes.  However, when I run the run.sh script I get the following error:

Traceback (most recent call last):
  File "./scripts/paster.py", line 34, in <module>
    command.run()
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteScript-1.7.3-py2.6.egg/paste/script/command.py",
 line 84, in run
    invoke(command, command_name, options, args[1:])
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteScript-1.7.3-py2.6.egg/paste/script/command.py",
 line 123, in invoke
    exit_code = runner.run(args)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteScript-1.7.3-py2.6.egg/paste/script/command.py",
 line 218, in run
    result = self.command()
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteScript-1.7.3-py2.6.egg/paste/script/serve.py",
 line 274, in command
    relative_to=base, global_conf=vars)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteScript-1.7.3-py2.6.egg/paste/script/serve.py",
 line 308, in loadserver
    relative_to=relative_to, **kw)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteDeploy-1.3.3-py2.6.egg/paste/deploy/loadwsgi.py",
 line 210, in loadserver
    return loadobj(SERVER, uri, name=name, **kw)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteDeploy-1.3.3-py2.6.egg/paste/deploy/loadwsgi.py",
 line 224, in loadobj
    global_conf=global_conf)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteDeploy-1.3.3-py2.6.egg/paste/deploy/loadwsgi.py",
 line 248, in loadcontext
    global_conf=global_conf)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteDeploy-1.3.3-py2.6.egg/paste/deploy/loadwsgi.py",
 line 278, in _loadconfig
    return loader.get_context(object_type, name, global_conf)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteDeploy-1.3.3-py2.6.egg/paste/deploy/loadwsgi.py",
 line 363, in get_context
    object_type, name=name)
  File 
"/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/eggs/PasteDeploy-1.3.3-py2.6.egg/paste/deploy/loadwsgi.py",
 line 528, in find_config_section
    self.filename))
LookupError: No section 'main' (prefixed by 'server') found in config 
/hpcdata/galaxy-test/galaxy-setup/galaxy-dist/universe_wsgi.ini

I have modified the universe_wsgi.ini to reflect the way our production server 
is configured.  The following is the server section of that file:

#
# Galaxy is configured by default to be useable in a single-user development
# environment.  To tune the application for a multi-user production
# environment, see the documentation at:
#
# http://bitbucket.org/galaxy/galaxy-central/wiki/Config/ProductionServer
#

# Throughout this sample configuration file, except where stated otherwise,
# uncommented values override the default if left unset, whereas commented
# values are set to the default value.
# examples of many of these options are explained in more detail in the wiki:
#
# Config hackers are encouraged to check there before asking for help.

# ---- HTTP Server ----------------------------------------------------------

# Configuration of the internal HTTP server.

[server:web0]
use = egg:Paste#http
port = 8080
host = 0.0.0.0
use_threadpool = true
threadpool_workers = 7

# Configuration of web server 2
[server:web1]
use = egg:Paste#http
port = 8081
host = 0.0.0.0
use_threadpool = true
threadpool_workers = 7

# Configuration of web server 3
[server:web2]
use = egg:Paste#http
port = 8082
host = 0.0.0.0
use_threadpool = true
threadpool_workers = 7

# The internal HTTP server to use.  Currently only Paste is provided.  This
# option is required.
#use = egg:Paste#http

# The port on which to listen.
#port = 8080

# The address on which to listen.  By default, only listen to localhost (Galaxy
# will not be accessible over the network).  Use '0.0.0.0' to listen on all
# available network interfaces.
#host = 0.0.0.0

# Use a threadpool for the web server instead of creating a thread for each
# request.
#use_threadpool = True

# Number of threads in the web server thread pool.
#threadpool_workers = 5

# ---- Filters --------------------------------------------------------------

# Filters sit between Galaxy and the HTTP server.

# These filters are disabled by default.  They can be enabled with
# 'filter-with' in the [app:main] section below.

# Define the gzip filter.
[filter:gzip]
use = egg:Paste#gzip

# Define the proxy-prefix filter.
[filter:proxy-prefix]
use = egg:PasteDeploy#prefix
prefix = /galaxy

My production server works fine, but this one will not run.  What am I missing?

Thanks,
Iry
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to