sys path is:

['/Users/paultanger/galaxy-dist/scripts',
'/Users/paultanger/python/scripts',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python26.zip',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/plat-darwin',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/plat-mac',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/plat-mac/lib-scriptpackages',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/lib-tk',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/lib-old',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/lib-dynload',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/site-packages',
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/site-packages/PIL',
'/Users/paultanger/galaxy-dist/lib']

pkg_resources is:
<module 'pkg_resources' from
'/Library/Frameworks/Python.framework/Versions/6.1/lib/python2.6/site-packages/pkg_resources.py'>



On Mon, Aug 29, 2011 at 8:17 AM, Paul Tanger <paul.tan...@colostate.edu>wrote:

> It is free for academic use.  I'll try what you suggested below - thanks!
>
>
> On Mon, Aug 29, 2011 at 7:59 AM, Nate Coraor <n...@bx.psu.edu> wrote:
>
>> Paul Tanger wrote:
>> > Yes it works with the default python install.  Any way I can get it
>> working
>> > with EPD python?
>>
>> I've never worked with EPD and since it's not free it's unlikely we can
>> do much debugging on it here.  It would appear that they bundle a
>> version of pkg_resources which changes the DistributionNotFound class,
>> but it's hard to know exactly what's going on here.
>>
>> One thing that might shed a bit of light on it would be to print
>> sys.path and pkg_resources at the top of:
>>
>>    galaxy-dist/lib/galaxy/eggs/__init__.py
>>
>> After the import of pkg_resources and see which version it's using.
>>
>> --nate
>>
>> >
>> > On Fri, Aug 26, 2011 at 12:43 PM, Nate Coraor <n...@bx.psu.edu> wrote:
>> >
>> > > Paul Tanger wrote:
>> > > > Has anyone gotten galaxy installed on a mac 10.5 with EPD
>> (enthought)
>> > > python
>> > > > 2.6 (EPD version 6.1-1)?  I get this error which I suspect is
>> related to
>> > > the
>> > > > fact that I have EPD python, not the generic python that was
>> > > preinstalled?
>> > > >  Any ideas?
>> > > >
>> > > > Thanks!
>> > > >
>> > > > Some eggs are out of date, attempting to fetch...
>> > > > Traceback (most recent call last):
>> > > >   File "./scripts/fetch_eggs.py", line 30, in <module>
>> > > >     c.resolve() # Only fetch eggs required by the config
>> > > >   File "/Users/paultanger/galaxy-dist/lib/galaxy/eggs/__init__.py",
>> line
>> > > > 345, in resolve
>> > > >     egg.resolve()
>> > > >   File "/Users/paultanger/galaxy-dist/lib/galaxy/eggs/__init__.py",
>> line
>> > > > 184, in resolve
>> > > >     if e.args[0].project_name != self.distribution.project_name:
>> > > > AttributeError: 'str' object has no attribute 'project_name'
>> > > > Fetch failed.
>> > >
>> > > Hi Paul,
>> > >
>> > > Can you give it a try with the system Python and see if you get the
>> same
>> > > result?  All you need to do is put:
>> > >
>> > >    /System/Library/Frameworks/Python.framework/Versions/2.6/bin
>> > >
>> > > At the head of your $PATH.
>> > >
>> > > Thanks,
>> > > --nate
>> > >
>> > > > ___________________________________________________________
>> > > > Please keep all replies on the list by using "reply all"
>> > > > in your mail client.  To manage your subscriptions to this
>> > > > and other Galaxy lists, please use the interface at:
>> > > >
>> > > >   http://lists.bx.psu.edu/
>> > >
>> > >
>>
>
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to