Hi,

we want to setup a local installation of Galaxy. It seems that Galaxy doesn't like the fact that we already have a different version of numpy installed. When following the installation instructions, we get following error messages:


Traceback (most recent call last):
  File "./scripts/fetch_eggs.py", line 30, in <module>
    c.resolve() # Only fetch eggs required by the config
  File "/home/galaxy/galaxy-new/galaxy-dist/lib/galaxy/eggs/__init__.py", line 
345, in resolve
    egg.resolve()
  File "/home/galaxy/galaxy-new/galaxy-dist/lib/galaxy/eggs/__init__.py", line 
195, in resolve
    return self.version_conflict( e.args[0], e.args[1] )
  File "/home/galaxy/galaxy-new/galaxy-dist/lib/galaxy/eggs/__init__.py", line 
226, in version_conflict
    r = pkg_resources.working_set.resolve( ( dist.as_requirement(), ), env, 
egg.fetch )
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 552, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: numpy==1.6.0

Note that we are using Debian and have already numpy 1.4.1 installed. How can we solve this problem without deinstalling numpy 1.4.1 (due to other dependencies)?

Thanks in advance!

Best,
Sebastian
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to