Hi Greg,

Thank you for your help. Your suggestion worked like a charm!

I was expecting to see an error because I did not create the ../shed_tool/ folder that contains the tools installed from the shed, but I was happy to see that it was automatically created.

I have a few additional comments and questions though:
1/ In the universe_wsgi.ini file, maybe the tool_config_file parameter could be renamed to tool_config_files (plural) to indicate that it takes a list of files. 2/ It seems like the Tools Search box cannot find newly installed tools. However, after I restart Galaxy, it works as intended again. 3/ In the Grinder wrapper, I relied on installing the wrapper under a specific folder: ./tools/ngs simulation/grinder. The new wrapper installation procedure installs the tools in the ../shed_tools/ folder and the admins can choose under what category the tool is to be placed. This means that my Grinder wrapper fails since it does not know where to find the scripts it needs. Is there a way to get the directory where a tool is installed? Here is an excerpt of the Grinder wrapper so you can better understand what I am trying to do. This wrapper first runs Grinder and then moves its files (the number of files is hard to determine ahead of time) to a place where Galaxy will find them (see the wiki page http://wiki.g2.bx.psu.edu/Admin/Tools/Multiple%20Output%20Files under section "Number of Output datasets cannot be determined until tool run").



#set $tool_dir = os.path.join( os.path.abspath($__root_dir__), 'tools', 'ngs_simulation' )
    #set $script1  = os.path.join( $tool_dir, 'stderr_wrapper.py' )
#set $script2 = os.path.join( $tool_dir, 'grinder_multiple_outputs.py' )

      #if $reference_file.specify == "builtin":
-reference_file ${ filter( lambda x: str( x[0] ) == str( $reference_file.value ), $__app__.tool_data_tables[ 'all_fasta' ].get_fields() )[0][-1] }
      #else if $reference_file.specify == "uploaded":
        -reference_file   $reference_file.value
      #end if
      #if str($homopolymer_dist):
        -homopolymer_dist $homopolymer_dist
      #end if

      #set $output_dir = $__new_file_path__
      -output_dir         $output_dir

      #set $base_name  = $output.id
      -base_name          $base_name

    $script2 $output_dir $base_name


On 04/10/11 22:55, Greg Von Kuster wrote:
Hello Florent,

Sorry for the confusion on this - we are preparing a new Galaxy distribution, 
and the tool shed wiki has been written in preparation for it.  The new 
distribution will be available fairly soon, and the Galaxy News Brief will 
include information about these new tool shed features.  In any case, you have 
already discovered that you can use in if you update your Galaxy instance to 
the latest Galaxy development repository ( Galaxy central ).

The problem you see is most likely caused by your not having configured an 
additional tool_config_file setting in your universe_wsgi.ini.  Look for 
something like following in your latest version of the universe_wsgi.ini.sample 
that you got when you updated from Galaxy central.

# Locally installed tools and tools installed from tool sheds
tool_config_file = tool_conf.xml,shed_tool_conf.xml

If you add a new additional file name like shed_tool_conf.xml, you should not 
have a problem installing from a tool shed.  I'll have a fix for the bug you've 
discovered shortly, but making this change will fix the behavior until then.

Let me know if you bump into any additional problems.

Thanks for finding this!

Greg Von Kuster

On Oct 4, 2011, at 2:53 AM, Florent Angly wrote:

Hi all,

I tried the latest stable version of Galaxy: 
http://wiki.g2.bx.psu.edu/News%20Briefs/2011_08_30. This page has links to how 
to use the new tool shed including how to automatically deploy tools from the 
shed in a local Galaxy server.
The documentation mentioned some tool shed options available from the the admin 
section of Galaxy but I could not locate these options in my instance of 
galaxy. So my question is: Can one only take advantage of the tool deployment 
from the shed in the development version of Galaxy? If so, I think the Tool 
shed wiki should be more clear about this.

Then I tried the latest development version of Galaxy and could locate the tool shed deployment options. I attempted to install the Grinder wrapper 
 but ran into an error that I am pasting below:
 line 364 in respond
  app_iter = self.application(environ, detect_start_response)
 line 98 in __call__
  environ, self.app)
 line 539 in intercept_output
  app_iter = application(environ, replacement_start_response)
 line 80 in __call__
  return self.application(environ, start_response)
 line 632 in __call__
  return self.application(environ, start_response)
line 160 in __call__
  body = method( trans, **kwargs )
 line 173 in decorator
  return func( self, trans, *args, **kwargs )
 line 805 in install_tool_shed_repository
  shed_tool_conf = trans.app.toolbox.shed_tool_confs.keys()[0].lstrip( './' )
IndexError: list index out of range
I get the same problem with other wrappers such as FastQC. Am I doing something 



The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:


To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

Greg Von Kuster
Galaxy Development Team

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to