Hi Kip,
I had exactly the same problem you had, but I finally got it working. So there is some hope :-) I am running Galaxy behind an Apache with RHEL 6.1. The default Apache provided by RH was 2.2.15 which gave me exactly the same error. So I upgraded to 2.2.21 using the src rpms from Fedora16 which did not help. But with being on 2.2.21 I patched the Apache server with the following file which finally solved the byte range issue:


http://svn.apache.org/viewvc?view=revision&revision=1177080

The bug is described here:
https://issues.apache.org/bugzilla/show_bug.cgi?id=51878
Galt Barber from UCSC Genome Browser already commented on this.

To be able to build Apache on your own you can do something like this:

# rpm -i /root/httpd-2.2.21-1.fc16.src.rpm
# cd /root/rpmbuild/SPECS
# rpmbuild -ba httpd.spec

We edited the httpd.spec file and removed the dependency to systemd-units so the following should work then.

# rpm -U
/root/rpmbuild/RPMS/x86_64/httpd-2.2.21-1.el6.x86_64.rpm
/root/rpmbuild/RPMS/x86_64/httpd-devel-2.2.21-1.el6.x86_64.rpm
/root/rpmbuild/RPMS/x86_64/httpd-tools-2.2.21-1.el6.x86_64.rpm
/root/rpmbuild/RPMS/x86_64/mod_ssl-2.2.21-1.el6.x86_64.rpm
/root/rpmbuild/RPMS/noarch/httpd-manual-2.2.21-1.el6.noarch.rpm

It might be helpful to work together with a Sysadmin.

Cheers
Manuel

--
Manuel Kohler
Center for Information Sciences and Databases (C-ISD)
Department of Biosystems Science & Engineering (D-BSSE)
ETH Zurich, Mattenstr. 26 (1058), CH-4058 Basel, +41 61 387 3132
Switzerland



On 14. October 2011 6:56 PM, Kip Bodi wrote:
Hi Brad,

They're binary BAM files. I followed the section below, but perhaps I
missed something. Thanks for the clarification on the Paste server, and
I think I'll try nginx next if I can't get forwarding through Apache to
work.

Cheers,

-Kip

On Thu, Oct 13, 2011 at 1:17 PM, Brad Chapman <chapm...@50mail.com
<mailto:chapm...@50mail.com>> wrote:


    Kip;
    Are these binary BAM or BigWig type files you are having trouble
    displaying at UCSC? I don't believe the Paste server has support for the
    byte-range requests that UCSC needs, and you need to send files through
    the proxy server. I've done this with nginx so don't have direct Apache
    experience here, but the 'Sending files using Apache' section here
    should get it working:

    http://wiki.g2.bx.psu.edu/Admin/Config/Apache%20Proxy

    Brad


     > Perhaps this is a distribution issue. For those who have gotten
    the "Display
     > at UCSC" link to work on a local server or workstation, what linux
     > distribution and version did you use? Has anyone used this
    successfully with
     > Red Hat Enterprise Linux 6.1?
     >
     > Best,
     >
     > -Kip
     >
     > On Fri, Oct 7, 2011 at 6:28 PM, Bodi, Kip <kip.b...@tufts.edu
    <mailto:kip.b...@tufts.edu>> wrote:
     >
     > > Hi all,
     > >
     > > I have a local galaxy instance, proxied by Apache, and am
    trying to get the
     > > 'display at UCSC' link to work. I've followed all of the
    instructions and am
     > > nearly there, but now I'm getting this response from UCSC when
    it tries to
     > > load the track:
     > >
     > > "Byte-range request was ignored by server. Expected Partial
    Content 206."
     > > etc.
     > >
     > > I think the error is because the PasteWSGIServer isn't allowing
    byte-range
     > > requests. When I look at the header, "Accept-Ranges: bytes" is
    not present:
     > > [galaxy@galaxy galaxy_dist]$ curl --head localhost
     > > HTTP/1.1 200 OK
     > > Date: Fri, 07 Oct 2011 22:23:49 GMT
     > > Server: PasteWSGIServer/0.5 Python/2.6.6
     > > content-type: text/html; charset=UTF-8
     > > Set-Cookie:
     > >
    
galaxysession=c6ca0ddb55be603a4e98b4f13a4db8bfb8635f0aa576697114d40b13a8355efe2cf7a075ef81d769;
     > > expires=Thu, 05-Jan-2012 17:23:49 GMT; Max-Age=7776000; Path=/;
    Version=1
     > > Vary: Accept-Encoding
     > > Connection: close
     > >
     > > Whereas on another server, "Accept-Ranges: bytes" appears in
    the header:
     > > [galaxy@galaxy galaxy_dist]$ curl --head apollo.med.tufts.edu
    <http://apollo.med.tufts.edu><
     > > http://apollo.med.tufts.edu>
     > > HTTP/1.1 403 Forbidden
     > > Date: Fri, 07 Oct 2011 22:22:42 GMT
     > > Server: Apache/2.2.21 (Fedora)
     > > Accept-Ranges: bytes
     > > Content-Length: 4609
     > > Connection: close
     > > Content-Type: text/html; charset=UTF-8
     > >
     > > I'm running RHEL6 with the latest version of galaxy-dist. I've
    tried
     > > manually enabling 'accept-ranges' but haven't had any luck. Any
    suggestions?
     > > Can I enable it somehow in universe_wsgi.ini?
     > >
     > > Best,
     > >
     > > -Kip




--
Kip Lord Bodi Jr.
Tufts University School of Medicine
136 Harrison Avenue, South Cove 502
Boston, MA 02118
617-636-3763 <tel:617-636-3763>
kip.b...@tufts.edu <mailto:kip.b...@tufts.edu>
www.tucf.org <http://www.tucf.org> | genomics.med.tufts.edu
<http://genomics.med.tufts.edu>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

   http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to