Sorry to hear it's not working for you - that link definitely did work
to an Australian Galaxy server behind a relatively tight and fussy
firewall.

Suggestions: check that it's not a local firewall problem - eg try
wget http://main.g2.bx.psu.edu/history/export_archive?id=735329393657ab63
or on the same link you're trying to import - it's just an archive.

If that works, then maybe check for an old version of the code your
Galaxy is running?
eg what does:

hg head

show from the root of the installation that's failing to import?

Is there anything interesting in paster.log after you start an import
job that never finishes?

On Tue, Oct 25, 2011 at 9:02 PM, Stefanie Ververs
<stefanie.verv...@fh-stralsund.de> wrote:
> Hi Ross,
>
> that is exactly what I tried - "Export to file" and then enter the link into
> "Import from File".
> But the History never appears in the account on our Galaxy :(
> It works between different accounts on main, but not from main to our's..
>
>
> Am 25.10.2011 11:58, schrieb Ross:
>>
>> Hi, Stefanie.
>>
>> I think you might want a URL pointing to an "archived history" if you
>> want to move your history to a different Galaxy?
>>
>> I imported your test history into my account on main, then I used the
>> 'export to file' option (it might not be optimally named since it
>> really creates an importable archive) - main returned:
>>
>> "Exporting History 'imported: Neue History zum Test'. Use this link to
>> download the archive or import it to another Galaxy server:
>> http://main.g2.bx.psu.edu/history/export_archive?id=735329393657ab63
>>
>> I just successfully imported from that URL to a private Galaxy and it
>> all looks right.
>>
>>
>> On Tue, Oct 25, 2011 at 6:48 PM, Stefanie Ververs
>> <stefanie.verv...@fh-stralsund.de>  wrote:
>>>
>>> Am 24.10.2011 21:05, schrieb Jeremy Goecks:
>>>>>
>>>>> So - I'm logged in and the link is accessible.
>>>>> (I tried with different accounts on the public server - that works; but
>>>>> not importing to our own instance.)
>>>>
>>>> The history must be "Accessible via link": Options -->    Share/Publish
>>>> -->
>>>>  Make History Accessible via Link
>>>>
>>>> Can you share the history with me?
>>>>
>>>> Thanks,
>>>> J.
>>>
>>> I tried it, following your instructions.
>>> And different follow-ups:
>>> 1) Pasting the "sharing"-Link into the "Import a History from an Archive"
>>> field ->  doesn't work
>>> 2) Opening the link being logged in to the account on OUR instance, that
>>> means, the target account, but NOT on the source account. ->  doesn't
>>> work -
>>> he tries to import the history on the public server (I assume because the
>>> message was about "this will delete your current history")
>>>
>>> When I imported histories from one account to another on the public
>>> server,
>>> I never used "Make History Accessible via Link". I just took the
>>> export-Link
>>> (the one you can download the history as an archive file.)
>>> I even tried uploading the file somewhere else.
>>>
>>> This is my test-History:
>>> http://main.g2.bx.psu.edu/u/stef85/h/neue-history-zum-test
>>>
>>> Steffi
>
>



-- 
Ross Lazarus MBBS MPH;
Associate Professor, Harvard Medical School;
Director of Bioinformatics, Channing Lab; Tel: +1 617 505 4850;
Head, Medical Bioinformatics, BakerIDI; Tel: +61 385321444;

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to