David,

I looked into this for some time, and although I found strange behavior in the 
mercurial environment, it is impossible to determine what caused it.  Your 
repository was definitely corrupted in some way, perhaps by a network problem 
that occurred when you were transferring files, or some other indeterminate 
issue.  In any case, I have recreated your repository from scratch so it is 
ready for you to upload your files once again.  From your change log, it was 
clear that you had deleted all files in the repository anyway.

I'll keep a watch on this.  Please let us know if you encounter further 
problems.  Sorry for the inconvenience with this.

Greg Von Kuster

On Oct 27, 2011, at 9:52 AM, David Murphy wrote:

> Just realized I didn't reply to all, so the list didn't see this.
> 
> No problem at all, it would be much appreciated in fact.
> 
> Is there anything I need to do to do so you can do that?
> 
> Cheers
> David
> 
> On Wed, Oct 26, 2011 at 9:28 PM, Greg Von Kuster <g...@bx.psu.edu> wrote:
> Hello David,
> 
> I'm not sure why you're seeing this - do you mind if I try to delete all of 
> the files in your repository whose name ends in '~'?  That may help me track 
> down the problem.
> 
> Greg Von Kuster
> 
> On Oct 26, 2011, at 3:09 PM, David Murphy wrote:
> 
> > Hi
> >
> > I've been trying to create a repository for a small tool called CodonLogo at
> > http://toolshed.g2.bx.psu.edu/.
> >
> > The problem is that the first zip I uploaded contained a few backup copies 
> > of
> > some text files ending with a "~".
> > It now won't allow me to delete them by checking them and clicking "delete
> > selected files" it then simply gives the error
> >
> > "The selected files were deleted from the repository.
> > Change set revision '7ff079013d98' includes no tools or exported workflows 
> > for
> > which metadata can be set."
> >
> > but the selected files are not deleted.
> >
> > When I try to upload a new zip without the older files it gives an error
> >
> > "Server Error
> > An error occurred. See the error logs for more information. (Turn debug on 
> > to
> > display exception reports here) "
> >
> > Am I doing something foolish or is this a bug?
> >
> > Cheers
> > David
> >
> > ___________________________________________________________
> > Please keep all replies on the list by using "reply all"
> > in your mail client.  To manage your subscriptions to this
> > and other Galaxy lists, please use the interface at:
> >
> >  http://lists.bx.psu.edu/
> 
> Greg Von Kuster
> Galaxy Development Team
> g...@bx.psu.edu
> 
> 
> 
> 

Greg Von Kuster
Galaxy Development Team
g...@bx.psu.edu



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to