Hi,

I'm running into this error:
"Error sorting alignments from (/tmp/5800600.1.all.q/tmpXOc5mD/tmpAZCzt_), "

When using SAM-to-BAM tool on a locally install Galaxy using a SGE
cluster. I'm using the last version of galaxy-dist. I'm guessing I
have a problem with the configuration for the tmp folder. I have this
on "universe_wsgi.ini":
# Temporary files are stored in this directory.
new_file_path = /home/cborroto/galaxy_dist/database/tmp

But I don't see this directory being used and from the error looks
like /tmp in the node is used. I wonder if this is the problem, as I
don't know if there is enough space in the local /tmp directory at the
nodes? I ran the same tool in a subset of the same SAM file and it ran
fine.

Also, I see this in the description of the tool:
"This tool uses the SAMTools toolkit to produce an indexed BAM file
based on a sorted input SAM file."

But what I actually need is to sort a SAM file output from bwa, I
haven't found any other way than to converting it to BAM. Looking at
"sam_to_bam.py" I see the BAM file will also be sorted. Would it be
wrong to feed an unsorted SAM file into this tool?

Finally, just to be sure there is nothing wrong with the initial SAM
file, I ran "samtools view ..." and "samtools sort ..." on this file
manually outside of Galaxy and it ran fine.

Thanks in advance,
Carlos
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to