A colleague of mine posted this on the Users list ... 4 days later and
no replies! I'm hoping that one of the Devs can shed a bit of light
------------------------------------------------------------------------
---------------------------------------------------
A peculiar bug, presented for your input:

A colleague has built a few tools and is trying to incorporate them into
a workflow. However:

1.       When he creates an new empty workflow, edits it and adds the
tools, they appear without inputs (i.e. the icons/boxes on the diagram
have no input "sockets")
2.       When he tries to save a history using these tools as a
workflow, a error results in which Galaxy complains about an
unrecognised name, being one of the tool inputs. Depending on which tool
he includes in the workflow, the missing name occurs in whichever tool
is earlier in the workflow. (Traceback available on request)

Puzzling. And even more puzzling when I tried to debug this:
1.       Other tools (not written by him) behave in the workflows as
expected.
2.       Pulling a copy of his config file across to my own instance of
Galaxy and creating a dummy tool to house it, it worked perfectly 
3.       We're running the same version of Galaxy, albeit different
versions of Python (2.5 vs 2.6.4)
4.       The tools work fine in normal analysis mode.
5.       Line-ending unix, XML seems to parse fine. 

I'm stymied here and unsure what to look at next. Ideas?
------------------------------------------------------------------------
---------------------------------------------------

Thanks

Steve

Dr Steven Platt
Bioinformatician
Health Protection Agency
Microbiology Services Division
London
www.hpa.org.uk/bioinformatics 
-----------------------------------------
**************************************************************************
The information contained in the EMail and any attachments is
confidential and intended solely and for the attention and use of
the named addressee(s). It may not be disclosed to any other person
without the express authority of the HPA, or the intended
recipient, or both. If you are not the intended recipient, you must
not disclose, copy, distribute or retain this message or any part
of it. This footnote also confirms that this EMail has been swept
for computer viruses, but please re-sweep any attachments before
opening or saving. HTTP://www.HPA.org.uk
**************************************************************************

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to