On Nov 25, 2011, at 6:52 AM, Ivan Merelli wrote:

> Hi,
> 
> I'm trying to use rgenetics in galaxy, but I have
> some problem in installting rpy-1.0.3 with R-2.13.1.
> 
> I found this guide, which is about the same problem of mine:
> http://gmod.827538.n3.nabble.com/Rpy-1-0-3-and-R-2-13-1-td3359590.html
> 
> but didn't work for me (although the part about the
> modulefile is quite obscure for me). The problem seems
> to be correlated to an header file (Rdevices.h) which
> is no more present in the latest R distribution.
> 
> Any hints to solve this
> problem? May I use rpy2?
> 
> Best,
> Ivan
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> 
> http://lists.bx.psu.edu/

There is information on solving this available via a web search - 
http://www.mail-archive.com/rpy-list@lists.sourceforge.net/msg01500.html for 
instance. In short, 

Unpack rpy-1.0.3 and patch the following files:
rpm_tools.py
   version = re.search(" +([0-9]\.[0-9]+\.[0-9])", output)
setup.py
include_dirs = [ os.path.join(RHOME.strip(), 'include'),                        
       'src', '/usr/share/R/include', '/apps/R/2.13.1/include' ]

* Build rpy with 
python setup.py install

Cheers,

Alex
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to