On 12/19/11 6:15 AM, liram_va...@agilent.com wrote:
Hi Jennifer,

Thank you again for the quick reply in my last issue.

I have another Galaxy problem and I hope you will be able to assist.
Because I am developing my Galaxy server while there are members in my group 
that are using this Galaxy instance in parallel,
I am trying to create another Galaxy process (instance), which will be used 
only for testing...

Therefore, I created a copy of Galaxy directory in other location (let say: 
/galaxy-dist_test)
And changed the listening port in "universe_wsgi.ini" to another port (8081).
Then, I tried to run both of Galaxy instances in parallel.
(One is listening on port 8080 and the other is on 8081)

The problem is occurred when I send a job for a run in one of the instance (let 
say: the one that run on 8080),
Then,  It cause to the another Instance (the one on port 8081) to collapse (And 
the history is disappeared...)

What is the problem?
How can I solve it?
How can I create two different and self-contained galaxy servers on the same 
computer?

I tried also to use the instructions :
http://wiki.g2.bx.psu.edu/Admin/Config/Performance/Web%20Application%20Scaling
But it was not helpful to my problem...

Thank you a lot!
Liram

-----Original Message-----
From: Jennifer Jackson [mailto:j...@bx.psu.edu]
Sent: Tuesday, November 29, 2011 4:42 PM
To: VARDI,LIRAM (A-Labs,ex1)
Cc: galaxy-...@bx.psu.edu
Subject: Re: [galaxy-dev] Can not clean my galaxy datasets

Hello Liram,

Perhaps the allow_user_dataset_purge option has not been set to True in 
universe_wsgi.ini?

Please see this wiki for details:
http://wiki.g2.bx.psu.edu/Admin/Disk%20Quotas#Quotas

Hopefully this helps, but please let us know if you need more assistance,

Best,

Jen
Galaxy team

On 11/29/11 5:44 AM, liram_va...@agilent.com wrote:
Hello,

My name is Liram Vardi and I'm using local Galaxy instance.

Anyway, I can't clean my deleted datasets from my own locally disk.

When I am trying to delete dataset, as was explained in
http://wiki.g2.bx.psu.edu/Learn/Managing%20Datasets#Actions,

First, I used the "delete 'X' icon" near the dataset to delete the
dataset,

Then, when I go to "Options ->  Show Deleted Datasets", I can see my
"deleted dataset" on the list

with the note: /"This dataset has been deleted. Click _here_ to
undelete it"//*but I don't get the also the option "or _here_ to
immediately remove it from disk."*/.

Also, when I use the option "Options ->  Purge Deleted Datasets", I'm
getting a message "0 datasets have been deleted permanently" and

my deleted dataset still stays in the "Options ->  Show Deleted Datasets"
menu list.

I also tried to clear the history, but when I'm doing that, the "using
X Mb" tab on the upper right corner is still not reset.

What is the problem?

Thanks a lot for your help!

Liram



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this and other
Galaxy lists, please use the interface at:

    http://lists.bx.psu.edu/

--
Jennifer Jackson
http://usegalaxy.org
http://galaxyproject.org/wiki/Support


--
Jennifer Jackson
http://usegalaxy.org
http://galaxyproject.org/wiki/Support
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to