Hi Hans,

Thank you for your reply.
Anyway, I tried to install Galaxy again by using the site "check-out" (hg clone 
https://...)  and it still cause problems.

Specifically, those were my steps:
1) I Installed galaxy in different location.
2) After run run.sh in the first time, I changed universe_wsgi.ini to listen on 
different port.
3) Manually, I copied "tools" and "tool-data" directories from the old instance 
of Galaxy to the new location (In order to get my new tools).
4) Also, I copied the old config tool file: " tool_conf.xml"
5) Then, Run the new Galaxy instance. In parallel, the old Galaxy is already 
"on line".

The problem is that any operation on the new Galaxy instance cause to the other 
Galaxy to
Throw the following error message:

URL: http://<ip address>.../user/login?use_panels=False
File 
'/home/liram/sdb1/galaxy-dist/eggs/WebError-0.8a-py2.7.egg/weberror/evalexception/middleware.py',
 line 364 in respond
  app_iter = self.application(environ, detect_start_response)
File 
'/home/liram/sdb1/galaxy-dist/eggs/Paste-1.6-py2.7.egg/paste/debug/prints.py', 
line 98 in __call__
  environ, self.app)
File '/home/liram/sdb1/galaxy-dist/eggs/Paste-1.6-py2.7.egg/paste/wsgilib.py', 
line 539 in intercept_output
  app_iter = application(environ, replacement_start_response)
.
.
.
.
File 
'/home/liram/sdb1/galaxy-dist/eggs/SQLAlchemy-0.5.6_dev_r6498-py2.7.egg/sqlalchemy/engine/base.py',
 line 931 in _handle_dbapi_exception
  raise exc.DBAPIError.instance(statement, parameters, e, 
connection_invalidated=is_disconnect)
OperationalError: (OperationalError) database is locked u'UPDATE galaxy_session 
SET update_time=?, is_valid=? WHERE galaxy_session.id = ?' ['2011-12-22 
10:27:05.978992', 0, 158]
       
I suppose that the problem is again caused due to collision between the 
databases. 
But how can I separate between them? 

Thanks you!!
Liram

-----Original Message-----
From: Hans-Rudolf Hotz [mailto:h...@fmi.ch] 
Sent: Wednesday, December 21, 2011 4:59 PM
To: VARDI,LIRAM (A-Labs,ex1)
Cc: galaxy-...@bx.psu.edu; BEN-DOR,AMIR (A-Labs,ex1)
Subject: running two Galaxy installations on one server - was: Re: [galaxy-dev] 
Can not clean my galaxy datasets

Hi Liram

I was suggesting: instead of copying the existing Galaxy directory into another 
location. Download and install a new Galaxy installation in a separate location 
on your file system.

for the installation procedure, see:

http://wiki.g2.bx.psu.edu/Admin/Get%20Galaxy

all you need to do in the new installation is changing the port number. 
It will create its own file system and by default it will use its own SQLite 
database. Hence, there should be no interference with your existing, production 
Galaxy installation.

Regards, Hans


On 12/21/2011 09:16 AM, liram_va...@agilent.com wrote:
> Hi Hans,
>
> Thank you for your quick reply.
>
> Sorry, But I'm a "rookie" Galaxy user, So may you pls explain me in 
> details the meaning by " running a second Galaxy server in parallel using a 
> fresh check-out "?
> Thank a lot for your assistance!
>
> Liram
>
> -----Original Message-----
> From: Hans-Rudolf Hotz [mailto:h...@fmi.ch]
> Sent: Monday, December 19, 2011 7:01 PM
> To: VARDI,LIRAM (A-Labs,ex1)
> Cc: Jennifer Jackson; Galaxy Dev; BEN-DOR,AMIR (A-Labs,ex1)
> Subject: Re: [galaxy-dev] Can not clean my galaxy datasets
>
> Hi Liram
>
> This sounds like the two Galaxy server use the same (PostgreSQL/MySQL) 
> database.
>
> Before copying your existing Galaxy server, you might wanna start with 
> running a second Galaxy server in parallel using a fresh check-out.
>
> Regards, Hans
>
>
> Have you tried to run a
>
> On 12/19/2011 04:08 PM, Jennifer Jackson wrote:
>>
>>
>> On 12/19/11 6:15 AM, liram_va...@agilent.com wrote:
>>> Hi Jennifer,
>>>
>>> Thank you again for the quick reply in my last issue.
>>>
>>> I have another Galaxy problem and I hope you will be able to assist.
>>> Because I am developing my Galaxy server while there are members in 
>>> my group that are using this Galaxy instance in parallel, I am 
>>> trying to create another Galaxy process (instance), which will be 
>>> used only for testing...
>>>
>>> Therefore, I created a copy of Galaxy directory in other location 
>>> (let
>>> say: /galaxy-dist_test)
>>> And changed the listening port in "universe_wsgi.ini" to another 
>>> port (8081).
>>> Then, I tried to run both of Galaxy instances in parallel.
>>> (One is listening on port 8080 and the other is on 8081)
>>>
>>> The problem is occurred when I send a job for a run in one of the 
>>> instance (let say: the one that run on 8080), Then, It cause to the 
>>> another Instance (the one on port 8081) to collapse (And the history 
>>> is disappeared...)
>>>
>>> What is the problem?
>>> How can I solve it?
>>> How can I create two different and self-contained galaxy servers on 
>>> the same computer?
>>>
>>> I tried also to use the instructions :
>>> http://wiki.g2.bx.psu.edu/Admin/Config/Performance/Web%20Application
>>> %
>>> 20Scaling
>>>
>>> But it was not helpful to my problem...
>>>
>>> Thank you a lot!
>>> Liram
>>>
>>> -----Original Message-----
>>> From: Jennifer Jackson [mailto:j...@bx.psu.edu]
>>> Sent: Tuesday, November 29, 2011 4:42 PM
>>> To: VARDI,LIRAM (A-Labs,ex1)
>>> Cc: galaxy-...@bx.psu.edu
>>> Subject: Re: [galaxy-dev] Can not clean my galaxy datasets
>>>
>>> Hello Liram,
>>>
>>> Perhaps the allow_user_dataset_purge option has not been set to True 
>>> in universe_wsgi.ini?
>>>
>>> Please see this wiki for details:
>>> http://wiki.g2.bx.psu.edu/Admin/Disk%20Quotas#Quotas
>>>
>>> Hopefully this helps, but please let us know if you need more 
>>> assistance,
>>>
>>> Best,
>>>
>>> Jen
>>> Galaxy team
>>>
>>> On 11/29/11 5:44 AM, liram_va...@agilent.com wrote:
>>>> Hello,
>>>>
>>>> My name is Liram Vardi and I'm using local Galaxy instance.
>>>>
>>>> Anyway, I can't clean my deleted datasets from my own locally disk.
>>>>
>>>> When I am trying to delete dataset, as was explained in 
>>>> http://wiki.g2.bx.psu.edu/Learn/Managing%20Datasets#Actions,
>>>>
>>>> First, I used the "delete 'X' icon" near the dataset to delete the 
>>>> dataset,
>>>>
>>>> Then, when I go to "Options ->  Show Deleted Datasets", I can see 
>>>> my "deleted dataset" on the list
>>>>
>>>> with the note: /"This dataset has been deleted. Click _here_ to 
>>>> undelete it"//*but I don't get the also the option "or _here_ to 
>>>> immediately remove it from disk."*/.
>>>>
>>>> Also, when I use the option "Options ->  Purge Deleted Datasets", 
>>>> I'm getting a message "0 datasets have been deleted permanently" 
>>>> and
>>>>
>>>> my deleted dataset still stays in the "Options ->  Show Deleted Datasets"
>>>> menu list.
>>>>
>>>> I also tried to clear the history, but when I'm doing that, the 
>>>> "using X Mb" tab on the upper right corner is still not reset.
>>>>
>>>> What is the problem?
>>>>
>>>> Thanks a lot for your help!
>>>>
>>>> Liram
>>>>
>>>>
>>>>
>>>> ___________________________________________________________
>>>> Please keep all replies on the list by using "reply all"
>>>> in your mail client. To manage your subscriptions to this and other 
>>>> Galaxy lists, please use the interface at:
>>>>
>>>> http://lists.bx.psu.edu/
>>>
>>> --
>>> Jennifer Jackson
>>> http://usegalaxy.org
>>> http://galaxyproject.org/wiki/Support
>>>
>>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to