Good afternoon Galaxy list,

I've got a Python script which calls an R script.  When I run a job using 
Galaxy, I get the following output from R:

Error in file(file, "r", encoding = encoding) : 
  cannot open the connection
In addition: Warning message:
In file(file, "r", encoding = encoding) :
  cannot open file 'rocprc.R': No such file or directory

The difficult thing here is that both scripts are in the same directory.  I 
tried using os.path.realpath(PYTHON SCRIPT) to get the name of the current 
directory so that I could force R to operate in same; I still get this error.  
Telling Python to print the results from os.path.realpath(PYTHON SCRIPT) gave 
me "~/galaxy-dist/database/job_working_directory".  Also, the Python script 
works perfectly when called from the command line, so I know this is a Galaxy 

Please help,
Kipper Fletez-Brant
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

Reply via email to