Hi,

Looking at workflow_execute.py, it seems to me there can be only one
input for step, is this correct? or is there a wait to map more than
one input and match them to an specific position in a  particularly
step?

This is the workaround I found.

I created 'Input Dataset' boxes for all of my inputs, then I linked
them to the step where they are needed. This is actually very
convenient if the same input is used in more than one step, as when I
run the workflow manually I only need to select each input once. I
tried doing this, as each 'Input Dataset' would have his own step.

This is an example workflow:
http://main.g2.bx.psu.edu/u/cjav/w/fastq-joiner---input-datasets

Initially I ran into this issue:
$ ./workflow_execute.py my_key http://main.g2.bx.psu.edu/api/workflows
fcfa9ae643d37c32 'Fastq joiner - Input Datasets'
'1=ldda=b4c5be159c8057c2' '2=ldda=ea0e32961d454539'
HTTP Error 400: Bad Request
"Workflow cannot be run because an expected input step '517620' has no
input dataset."

I then found you can do:
$ ./display.py my_key http://main.g2.bx.psu.edu/api/workflows/fcfa9ae643d37c32
Member Information
------------------
url: /api/workflows/fcfa9ae643d37c32
inputs: {'517620': {'value': '', 'label': 'Left-hand Reads'},
'517622': {'value': '', 'label': 'Right-hand Reads'}}
id: fcfa9ae643d37c32
name: Fastq joiner - Input Datasets


I see inputs get different keys and I can use them when executing the workflow:
$ ./workflow_execute.py my_key http://main.g2.bx.psu.edu/api/workflows
fcfa9ae643d37c32 'hist_id=9fbfd3a1be8b7f8e'
'517620=hda=8d89405199368bb0' '517622=hda=5c93f30078e5ac25'
Response
--------
{'outputs': ['f7c4b0900d8f3b1b'], 'history': '9fbfd3a1be8b7f8e'}

This worked perfectly. I still think it would be easier to be able to
use the step number, but this works.


Lastly, I did run into one issue where I had to import the datasets
firsts, as trying to use ldda like this:
$ ./workflow_execute.py my_key http://main.g2.bx.psu.edu/api/workflows
fcfa9ae643d37c32 'Fastq joiner - Input Datasets'
'517620=ldda=b4c5be159c8057c2' '517622=ldda=ea0e32961d454539'
Response
--------
{'outputs': ['44c033fad737acc5'], 'history': '9fbfd3a1be8b7f8e'}

I got this error in the history:
input data 1 (file:
/galaxy/main_database/files/002/780/dataset_2780871.dat) was deleted
before the job started

This didn't happen in our local instance using galaxy-central.

Thanks,
Carlos
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to