Hi,

I tried a few more things. I see when I try to update a dataset in a
library the "The resource could not be found" goes a way, although
still nothing gets updated:
./update.py <my_key>
http://localhost:8080/api/libraries/f2db41e1fa331b3e/contents/8c49be448cfe29bc
name=foobar
Response
--------
None

The dataset doesn't get updated.

Is it possible to update datasets in a history? If so, how?. And, what
I'm still doing wrong here causing the dataset in the library not to
get updated?

Thanks in advance for any help,
Carlos


On Fri, Jan 13, 2012 at 4:56 PM, Carlos Borroto
<carlos.borr...@gmail.com> wrote:
> Hi,
>
> I'm trying to use the update.py script and is not clear for me what to
> use for 'url' in the usage line:
> usage: create.py key url [key=value ...].
>
> Which I'm guessing is just a carry over from create.py.
>
> I tried passing the direct link to the dataset:
> $ ./update.py <my_key>
> http://localhost:8080/api/histories/0397e7c5778be5ee/contents/45d854c903d27dcf
> name=foobar
> HTTP Error 404: Not Found
> 404 Not Found
> The resource could not be found.
> No action for /api/histories/0397e7c5778be5ee/contents/45d854c903d27dcf
>
> Just to show you this dataset does exists:
> $ ./display.py <my_key>
> http://localhost:8080/api/histories/0397e7c5778be5ee/contents/45d854c903d27dcf
> Member Information
> ------------------
> misc_blurb: 4.3 Gb
> name: BMD01.GAIIx.1.fastq
> data_type: fastqillumina
> deleted: False
> state: ok
> download_url: /datasets/45d854c903d27dcf/display?to_ext=fastqillumina
> visible: True
> genome_build: ?
> model_class: HistoryDatasetAssociation
> metadata_sequences: None
> file_size: 4644313368
> metadata_data_lines: None
> id: 45d854c903d27dcf
> misc_info: uploaded fastq file
> metadata_dbkey: ?
>
> Thanks,
> Carlos
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to