On Jan 24, 2012, at 4:16 PM, Lucilla Luzi wrote:

> ERRATA CORRIGE: sorry :(
> 
> $ echo $PATH
> /System/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
> 
> -------- Original Message --------
> Subject:     [galaxy-dev] Some eggs are out of date...Fetch failed (Mac OS X 
> 10.6)
> Date:     Tue, 24 Jan 2012 22:06:42 +0100
> 
> 
> Hi,
> 
> I'm pretty new to Galaxy, at least to this side.
> I'm sorry to bother you with my issue, that, I read, was quite extensively 
> discussed previously, but even if I think to have followed 
> correctly the instruction and further suggestions, I'm still not able to 
> overcome the problem.
> 
> I'm trying to install a local instance of Galaxy on my MAC (OS X10.6.8) 
> My Python version is 2.6.1 and I just installed Mercurial 2.0.2 for MacOS X 
> 10.6. 
> 
> FYI
> 
> $ python --version
> Python 2.6.1
> 
> --->> wrong  <<---see above
> $ echo $PATH
> /Users/myName/System/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
> 
> When I try to run the run.sh I get the error attached below.
> Can you envisage a possible reason why I'm getting this error?
> Sorry for the naive admission, but from the error message 
> I'm not even capable to understand which are the "missing eggs"...
> 
> If I'd have ignored a previous post with the solution, I apologize in advance.
> Thank you a lot for your attention.

Hi Lu,

Could you provide the output of the following?:

% python ./scripts/get_platforms.py

Thanks,
--nate


> Lu
> 
> ------------------
> $ sh run.sh
> Some eggs are out of date, attempting to fetch...
> Traceback (most recent call last):
>   File "./scripts/fetch_eggs.py", line 30, in <module>
>     c.resolve() # Only fetch eggs required by the config
>   File 
> "/Users/myName/My_programs/Galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", 
> line 345, in resolve
>     egg.resolve()
>   File 
> "/Users/myName/My_programs/Galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", 
> line 195, in resolve
>     return self.version_conflict( e.args[0], e.args[1] )
>   File 
> "/Users/myName/My_programs/Galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", 
> line 226, in version_conflict
>     r = pkg_resources.working_set.resolve( ( dist.as_requirement(), ), env, 
> egg.fetch )
>   File 
> "/System/Library/Frameworks/Python.framework/Versions/2.6/Extras/lib/python/pkg_resources.py",
>  line 518, in resolve
>     raise DistributionNotFound(req)  # XXX put more info here
> pkg_resources.DistributionNotFound: numpy==1.6.0
> Fetch failed.
> 
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> 
>  http://lists.bx.psu.edu/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to