PS: when I make the section empty again in the original tool_conf.xml it 
doesn't show up anymore in that section. :-(
Actually the complete section is again invisible.

Van: galaxy-dev-boun...@lists.bx.psu.edu 
[mailto:galaxy-dev-boun...@lists.bx.psu.edu] Namens Bossers, Alex
Verzonden: maandag 6 februari 2012 8:45
Aan: 'Greg Von Kuster'; Ira Cooke
CC: galaxy-dev@lists.bx.psu.edu Dev
Onderwerp: Re: [galaxy-dev] Problem fetching updates to toolshed tool

Hi Greg,

Ok I pulled the latest changeset and updated the database. No probs.
Now I am able to get tools from the galaxy main toolshed. Tested the table2html 
tool to be sure about no additional dependencies. It came up nicely with the 
section list I can install a tool to; but...
I created an EMPTY section in the tool_conf.xml menu where I want the toolshed 
tools to go to at the moment. To keep it maintainable for now at testing. But 
It does not show up in the bullet list of sections to install to (as these 
sections also do not show up in the menu itself until they cotain a valid tool 
xml). Other custom sections are there.
Part of the tool_conf.xml
  </section>
<label text="External tools" id="externaltools" />
  <section name="ToolShed auto tools" id="toolshedtools">
  </section>

I added an empty <tool file="" /> line in the section and still not there. 
Adding a valid tool lets it show up in the bullit list as it now also shows up 
in the left panel.. (as expected).
Another test on the EMPTY section when I tried adding the tool providing THE 
SAME section name as custom in the field as a new tool panel section... it just 
adds it to the end of the section lists in the left. But it does work.
It also remains working when I enable my own section menu again by adding 
another tool to the xml first. The section with the same name shows up on two 
places in the section list when adding tools from toolshed (as expected). 
Probably due to the different section id. There might be a possible problem 
when the id turns out the same as an already used one?

I manually altered the shed_tool_conf.xml to match my section name and id and 
everything is ok.

Maybe something to look into? Just a minor issue I think.

Keep up the good work!
Alex



Van: 
galaxy-dev-boun...@lists.bx.psu.edu<mailto:galaxy-dev-boun...@lists.bx.psu.edu> 
[mailto:galaxy-dev-boun...@lists.bx.psu.edu]<mailto:[mailto:galaxy-dev-boun...@lists.bx.psu.edu]>
 Namens Greg Von Kuster
Verzonden: vrijdag 3 februari 2012 22:16
Aan: Ira Cooke
CC: galaxy-dev@lists.bx.psu.edu<mailto:galaxy-dev@lists.bx.psu.edu> Dev
Onderwerp: Re: [galaxy-dev] Problem fetching updates to toolshed tool

Things should be working in change set 6667:86d9c5ddbafc, which is now 
available from the Galaxy central repository.  Please let me know if you bump 
into any problems.

To use the latest features related to tool versioning, update your local tool 
shed as well as your local Galaxy instance ( both require updating the database 
schema ).  In your local tool shed, reset all metadata for each repository 
using the Repository Actions pop-up for each repository.  Since you already 
have repositories in your tool shed, you'll need to do this once for each 
existing repository.  Any updates to the repository will automatically do this. 
 New repositories created from here on will handle this automatically as well.


Then, in your local Galaxy instance, set tool versions for each installed tool 
shed repository using the repository's pop-up.





On Feb 3, 2012, at 11:07 AM, Greg Von Kuster wrote:

> Hello Ira,
>
> Thanks for reporting this - there are several similar issues that I've 
> corrected in my next change set, which will be available today.  This change 
> set will introduce tool versioning for Galaxy tools, whether they are 
> installed from a tool shed, or are available with the distribution.  This 
> will affect the tool shed as well as repositories installed from tool sheds 
> that contain tools.  This versioning feature will provide a chain of ancestor 
> tool versions and descendant tool versions for any tool instance.
>
> It would be great if you and others that have set up local Galaxy tool sheds 
> can test this out.  I will get fixes for issues (if any exist) as fast as 
> possible.  My hope is that this will be the last major feature introduced 
> until we get everything stabilized a bit more between the tool shed and 
> Galaxy.
>
> Thanks!
>
> Greg Von Kuster
>
>
> On Feb 2, 2012, at 8:40 PM, Ira Cooke wrote:
>
>> Hi,
>>
>> We've been running into an issue when attempting to create a new toolshed 
>> tool.  We have the toolshed and the main galaxy web app setup and running, 
>> but updating our tool to the latest version always fails.
>>
>> When clicking "Get updates" on our installed tool we find that the initial 
>> request is sent fine to the community application, but the reply is missing 
>> a slash after the galaxy url.  This causes the request to fail.
>>
>> Our solution to this problem was to modify 
>> lib/galaxy/webapps/community/controllers/repository.py on line 795 to 
>> include a slash after the galaxy url.
>>
>> After we did this though we encountered another problem .. this time in 
>> lib/galaxy/web/controllers/admin_toolshed.py .  In this case there is a 
>> named parameter to a method but the name of the parameter does not match the 
>> method definition.  The problem was on 688 where "name = name" should read 
>> "repository_name=name".
>>
>> After making these changes the get updates function seems to work fine.
>>
>> Hope this helps.
>> Ira
>>
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>
>> http://lists.bx.psu.edu/
>
> Greg Von Kuster
> Galaxy Development Team
> g...@bx.psu.edu<mailto:g...@bx.psu.edu>
>
>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>  http://lists.bx.psu.edu/

Greg Von Kuster
Galaxy Development Team
g...@bx.psu.edu<mailto:g...@bx.psu.edu>

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to