Hi Galaxy Team,

I am running a small local instance of Galaxy and I've run into a database  
error following an upgrade to the Jan27th  galaxy-dist release.

The last line when I run run.sh tells me to upgrade my database:

        Exception: Your database has version '85' but this code expects version 
'90'.  Please backup your database and then migrate the schema by running 'sh 
manage_db.sh upgrade'.

But when I run the manage_db.sh  I run into the following errors:


$ sh manage_db.sh 
Traceback (most recent call last):
  File "./scripts/manage_db.py", line 12, in <module>
    from migrate.versioning.shell import main
  File 
"/home/galaxy/galaxy-dist/eggs/sqlalchemy_migrate-0.5.4-py2.7.egg/migrate/versioning/shell.py",
 line 7, in <module>
    from migrate.versioning.base import *
  File 
"/home/galaxy/galaxy-dist/eggs/sqlalchemy_migrate-0.5.4-py2.7.egg/migrate/versioning/base/__init__.py",
 line 5, in <module>
    from const import databases,operations
  File 
"/home/galaxy/galaxy-dist/eggs/sqlalchemy_migrate-0.5.4-py2.7.egg/migrate/versioning/base/const.py",
 line 7, in <module>
    from sqlalchemy.util import OrderedDict
ImportError: No module named sqlalchemy.util
 

The first thing that pops out is that I the sqlalchemy egg is part of py2.7 
while I am using python2.6.  Any suggestions on how to troubleshoot this?


thanks,
zach cp






___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to