Dear list,

I am trying to deploy Galaxy as an environment for proteomics tools in amazon's EC2 cloud, probably/preferably via Cloudman. I have used both the biocloudcentral portal and a manual approach to set up cloudman/galaxy, but run into the same error message which seems to start with a problem with a snapshot that does not exist:


 * 15:16:05 - PostgreSQL data directory '/mnt/galaxyData/pgsql/data'
   does not exist (yet?)
 * 15:16:26 - Error creating volume: EC2ResponseError: 400 Bad Request
   |InvalidSnapshot.NotFound|The snapshot 'snap-b28be9d5' does not
   exist.---some long identifier---
 * 15:16:26 - Error adding filesystem service 'Filesystem-galaxyTools':
   'NoneType' object has no attribute 'id'
 * 15:16:26 - STATUS CHECK: File system named 'galaxyTools' is not
   mounted. Error code 0
 * 15:16:37 - Error mounting file system '/mnt/galaxyData' from
   '/dev/xvdg2', running command '/bin/mount /dev/xvdg2
   /mnt/galaxyData' returned code '32' and following stderr: 'mount:
   you must specify the filesystem type '


My instance type is t1.micro (testing on AWS free tier), but I've tried m1.large, and that didn't help. I noted that the snapshot ID is always the same. Since the AMI is from March 2011 (at least the one I select manually), I assume that I have something wrong in my settings or that Amazon has changed something somewhere.

cheers,
Jorrit Boekel
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to