Greg Von Kuster <greg@...> writes:

> 
> Hi Alex,
> The ToolSectionLabel element is causing the problem as it is not currently
supported in the new tool shed repository installation implementation.  I'll try
to get a fix for this today.  In the meantime, eliminating the section label
from your tool config should work as a temporary workaround.  I'll send you a
note when I have the fix - sorry for the inconvenience.
> 
> FYI - I have a fairly complex change set coming today that will introduce tool
versioning for Galaxy tools, whether they are installed from a tool shed, or are
available with the distribution.  This will affect the tool shed as well as
repositories installed from tool sheds that contain tools.  This versioning
feature will provide a chain of ancestor tool versions and descendant tool
versions for any tool instance.  
> 
> It would be great if you and others that have set up local Galaxy tool sheds
can test this out.  I will get fixes for issues (if any exist) as fast as
possible.  My hope is that this will be the last major feature introduced until
we get everything stabilized a bit more between the tool shed and Galaxy.
> 
> Thanks!
> 
> Greg Von Kuster
> 
> 
> On Feb 3, 2012, at 10:20 AM, Bossers, Alex wrote:
> 
> Somehow I seem to miss something when configuring our latest up-to-date
galaxy_central version to use the galaxy toolshed.
> When as admin I want to install a tool I can browse the given 2 repositories
and select view tools.
> When I select install to local galaxy it drops an error on 2 tools I tested
thus far:
>  
> ---------------------------
> Error Traceback:
> View as:   Interactive  |  Text  |  XML (full)
> ⇝ AttributeError: 'ToolSectionLabel' object has no attribute 'name'
>
URL: http://galaxy02:8080/galaxy/admin_toolshed/install_repository?tool_shed_url=http://toolshed.g2.bx.psu.edu&repo_info_dict=293ac398f098023d041933b74935d0b4771444a6:7b22636f646f6e6c6f676f223a205b22436f646f6e2062617365642073657175656e6365206c6f676f2067656e657261746f722e222c2022687474703a2f2f746f6f6c736865642e67322e62782e7073752e6564752f7265706f732f64617669646d75727068792f636f646f6e6c6f676f222c2022323037313634353062653837225d7d&includes_tools=True
> 
> Module weberror.evalexception.middleware:364 in respond         view
> >>  app_iter = self.application(environ, detect_start_response)
> Module paste.debug.prints:98 in __call__         view
> >>  environ, self.app)
> Module paste.wsgilib:539 in intercept_output         view
> >>  app_iter = application(environ, replacement_start_response)
> Module paste.recursive:80 in __call__         view
> >>  return self.application(environ, start_response)
> Module paste.httpexceptions:632 in __call__         view
> >>  return self.application(environ, start_response)
> Module galaxy.web.framework.base:160 in __call__         view
> >>  body = method( trans, **kwargs )
> Module galaxy.web.framework:173 in decorator         view
> >>  return func( self, trans, *args, **kwargs )
> Module galaxy.web.controllers.admin_toolshed:322 in install_repository        
view
> >>  tool_panel_section_select_field = build_tool_panel_section_select_field(
trans )
> Module galaxy.web.controllers.admin_toolshed:804 in
build_tool_panel_section_select_field         view
> >>  options.append( ( tool_section.name, tool_section.id ) )
> AttributeError: 'ToolSectionLabel' object has no attribute 'name'
> ---------------------------
>  
>  
> The steps I took:
> Updated the universe to load the extra shed_tool_conf.xml file.
> Set the toolpath to "../toolshedtools" in shed_tool_conf.xml
> Gave the directory read write permissions for galaxy user:dev_group
> Restarted galaxy.
>  
> Any additional configs to make somewhere? In the original tool_conf.xml file?
>  
> Alex
>  
>  ___________________________________________________________Please keep all
replies on the list by using "reply all"in your mail client.  To manage your
subscriptions to thisand other Galaxy lists, please use the interface
at: http://lists.bx.psu.edu/
> 
> 
> 
> Greg Von Kuster
> Galaxy Development Team
> g...@bx.psu.edu
> 
> 
> 
> 
> 
Hi Greg,
I got the exactly same error today. I can install tools from main tool shed
before without any problem.

I tried hg incoming and hg pull -u to update my local instance.

Here is the result for hg summary

(galaxy_env)galaxy@osbc-147:~/galaxy-dist$ hg summary
parent: 6621:26920e20157f tip
 Improve language in 'Import workflow' dialog.
branch: default
commit: 34 modified, 93 unknown
update: (current)

It looks like we are using diff branch (?) How could I apply your modification?
Also I am not using local tool shed either. 

Thanks

Lisa



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to