Hi,

For our fresh new local instance I created a user. But whenever I try to login it looks like I end up as anonymous user again. And if I click "Workflows" I'm told that I need to login first.


The only thing that looks like an error message is this one:
"galaxy.web.framework DEBUG 2012-03-22 16:38:42,570 Error: this request returned None from get_history(): http://bbc.mdc-berlin.de/galaxy/workflow";

I'm running behind an Apache, could that be the reason?

My Apache config:

RewriteRule ^/galaxy$ /galaxy/ [R]
RewriteRule ^/galaxy/static/style/(.*) 
/opt/galaxy/galaxy-dist/static/june_2007_style/blue/$1 [L]
RewriteRule ^/galaxy/static/scripts/(.*) 
/opt/galaxy/galaxy-dist/static/scripts/packed/$1 [L]
RewriteRule ^/galaxy/static/(.*) /opt/galaxy/galaxy-dist/static/$1 [L]
RewriteRule ^/galaxy/favicon.ico /opt/galaxy/galaxy-dist/static/favicon.ico [L]
RewriteRule ^/galaxy/robots.txt /opt/galaxy/galaxy-dist/static/robots.txt [L]
RewriteRule ^/galaxy(.*) http://database1:8080$1 [P]


universe_wsgi.conf

...
[filter:proxy-prefix]
use = egg:PasteDeploy#prefix
prefix = /galaxy
...

[app:main]

...

# Allow unregistered users to create new accounts (otherwise, they will have to
# be created by an admin).
#allow_user_creation = True

# Allow administrators to delete accounts.
#allow_user_deletion = False

# Allow administrators to log in as other users (useful for debugging)
#allow_user_impersonation = False


regards, Andreas

--
Andreas Kuntzagk

SystemAdministrator

Berlin Institute for Medical Systems Biology at the
Max-Delbrueck-Center for Molecular Medicine
Robert-Roessle-Str. 10, 13125 Berlin, Germany

http://www.mdc-berlin.de/en/bimsb/BIMSB_groups/Dieterich
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to