Hello,

Great work with the Galaxy on the Cloud - it's the first time I've used it and 
it looks very impressive (and I'm not a big cloud fan :) ).

Once I got it working it was very nice, but before it worked I encountered two 
issues (not sure if those were voodoo or not) that could be perhaps documented 
in the Wiki (under "troubleshooting"?):

1. the "User Data" is sensitive to trailing white-space, or senstive to 
copy&paste in the edit box.

I accidentally had:
  access_key: XXXXXXXXXXXXXX<space><space>
and it seems it completely prevent the Cloudman from starting.
when the stared, I couldn't connect to it with a web-browser.
I logged on using SSH, and saw that there was nothing running/listening on port 
80 (no nginx, no python).
Not sure exactly why it happened, but it did.
removing white-space (and also saving the user-data to a file instead of 
pasting it directly in the editbox) solved the problem.


2. If the "user-data" password is all numeric, there's no way to login to the 
cloudman.
I suspect the reason is that an all numeric password is treated as a number, 
not a string.
Then, the log shows:

$ cat /opt/galaxy/pkg/ec2autorun.py.log
[...]
[DEBUG] ec2autorun:337 2012-04-13 20:22:50,983: Composed user data: 
{'access_key': 'XXXXXXXXXXXXXXXXXX', 'cloudman_home': '/mnt/cm', 
'cluster_name': 'galaxy-TGAC-workshop', 'bucket_default': 'cloudman', 'role': 
'master', 'bucket_cluster': 'cm-169ca4be88c386ce8ec3078d69a6dc3a', 
'boot_script_path': '/tmp/cm', 'boot_script_name': 'cm_boot.py', 'secret_key': 
'XXXXXXXXXXXXX', 'password': 12345678}
[...]

you'll notice that the password key is a numeric value, not a string - and 
login wasn't possible (perhaps it was voodoo and I'm wrong in my guess, but 
once I changed it to alphanumeric password, with the same user data settings, 
it workd).



-gordon


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to