Hello Paul,

I apologize for somehow missing the first line of your paster log, which in 
fact shows the upload step.  Since you've tried uploading various files with no 
success, the problem is likely to be caused by something specific to your 
environment - possibly the version of the mercurial package you're using.  What 
version of Python are you running, and what version of the mercurial package do 
you have installed with it?  Also, what version of Galaxy do you have, and what 
database / version are you using?

I recently interacted with a developer who was setting up a local tool shed 
using Centos6.2 and was not able to create a repository - a slightly different 
issue than you have, but his problem stemmed from the old version of the 
mercurial package that was installed.  Here's what he did:

========
- Mercurial has version 1.4. <--- THIS IS THE PROBLEM (default in the repo of 
Centos6.2) -- see below

So I decided to remove the mercurial version 1.4 and do a source install of the 
latest version 2.1.2. After installing, as user Galaxy I confirm a correct 
installation with:

[galaxy@galaxy galaxy-dist]$ hg debuginstall
Checking encoding (UTF-8)...
Checking installed modules 
(/usr/local/lib64/python2.6/site-packages/mercurial)...
Checking templates 
(/usr/local/lib64/python2.6/site-packages/mercurial/templates)...
Checking commit editor...
Checking username...
No problems detected

However, after this I still have to set the PYTHONPATH variable (otherwise, 
python does not find mercurial):
export PYTHONPATH=/usr/local/lib64/python2.6/site-packages/:${PYTHONPATH}

And our toolshed runs now, without errors. :-D
===========

Can you let me know the versions of the various components I've listed above, 
and whether upgrading the version of the mercurial package you are using fixes 
this?

Thanks,

Greg Von Kuster


On Apr 18, 2012, at 4:12 AM, Paul-Michael Agapow wrote:

> Picking up on this thread, I said:
> 
>> As per the title, I'm trying to setup a toolshed for our local use. After 
>> creating a repo, I try to upload the initial file only to get:
>> 
>>   TypeError: array item must be char
>> 
>> Which seems to happen repeatedly, i.e. it's not a passing error.
> 
> And Greg said:
> 
>> Regarding this issue, your initial problem was regarding uploading a file to 
>> a repository that you successfully created, but your
>> pater log does not include anything about uploading.  Can you clarify what 
>> the problem is?  I'll need as much context as you can
>> provide.  For example, have you successfully created a new repository?  If 
>> so, is the problem still that you cannot upload a file
>> to it?  If this is the case, can you send me the file you are attempting to 
>> upload?  What are the contents of your hgweb.config
>> file, which is located in you Galaxy install directory?
> 
> So, to recap:
> 
> * I'm testing out using a local toolshed
> * I install (via hg) a brand new Galaxy instance
> * I configure and fire up the toolshed
> * Create a repository
> * This works fine. I go to upload a file and I get:
> 
> URL: http://158.119.147.40:9009/upload/upload?repository_id=529fd61ab1c6cc36
> Module paste.exceptions.errormiddleware:144 in __call__
>>> app_iter = self.application(environ, sr_checker)
> Module paste.debug.prints:106 in __call__
>>> environ, self.app)
> Module paste.wsgilib:543 in intercept_output
>>> app_iter = application(environ, replacement_start_response)
> Module paste.recursive:84 in __call__
>>> return self.application(environ, start_response)
> Module paste.httpexceptions:633 in __call__
>>> return self.application(environ, start_response)
> Module galaxy.web.framework.base:160 in __call__
>>> body = method( trans, **kwargs )
> Module galaxy.web.framework:86 in decorator
>>> return func( self, trans, *args, **kwargs )
> Module galaxy.webapps.community.controllers.upload:126 in upload
>>> repo.commit( user=trans.user.username, text=commit_message )
> Module mercurial.localrepo:1195 in commit
>>> ret = self.commitctx(cctx, True)
> Module mercurial.localrepo:1264 in commitctx
>>> p2.manifestnode(), (new, drop))
> Module mercurial.manifest:147 in add
>>> arraytext = array.array('c', text)
> TypeError: array item must be char
> 
> * This happens repeatedly on different files (tried with several different 
> text files, pdfs etc., but not with any archives/zips), or with different 
> repositories, and after restart. 
> * hgweb.config looks fine I think, showing two (non-uploadable-to) repos
> 
> [paths]
> repos/agapow/gfdfd = database/community_files/000/repo_1
> repos/agapow/testrepo = database/community_files/000/repo_2
> 
> * The paster log (community_webapp.log, see http://pastebin.com/ysgnHwcz), 
> shows the upload call failing with the "array item must be char" (lines 98, 
> 124 and elsewhere)
> * Other toolshed browsing etc functions see to work fine
> * Running CentOS 4
> 
> Not sure where to look next. Any ideas?
> 
> ----
> Paul Agapow (paul-michael.aga...@hpa.org.uk)
> Bioinformatics, Health Protection Agency
> 
> -----------------------------------------
> **************************************************************************
> The information contained in the EMail and any attachments is
> confidential and intended solely and for the attention and use of
> the named addressee(s). It may not be disclosed to any other person
> without the express authority of the HPA, or the intended
> recipient, or both. If you are not the intended recipient, you must
> not disclose, copy, distribute or retain this message or any part
> of it. This footnote also confirms that this EMail has been swept
> for computer viruses, but please re-sweep any attachments before
> opening or saving. HTTP://www.HPA.org.uk
> **************************************************************************
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> 
> http://lists.bx.psu.edu/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to