Hi Hans,

Here is my XML file in a simplificated version (no <conditionnal> 
parameters) , -i -r and -k are the mandatory arguments of my tool, 
written in C++:


<tool id="myTool" name="myTool">

   <description> the description </description>

   <command interpreter="C++"> 
/home/myName/work/galaxy-dist/tools/NGStools/myTool 
     -i="${genome_index}"
     -r="${input}"
     -k="${kmer_length}"
     -o="${output_name}"
   </command>

   <inputs>
      <param name="i" type="select" label="Genome index"> 
         <option value="Human"> path/to/Human </option>
         <option value="E.coli"> path/to/Escherichia coli </option>
      </param>

      <param format="txt" name="r" type="data" label="Source File" help="Select 
a file"/>   
      <param format="raw" name="r" type="data" label="Source File" help="Select 
a file"/> 
      <param format="doc" name="r" type="data" label="Source File" help="Select 
a file"/> 
      <param format="fastq" name="r" type="data" label="Source File" 
help="Select a file"/>

     <param name="kmer_length" type="integer" min="15" max="150" value="21" 
label="k-mer length"/> 
         
    
      <param name="o" type="text" optional="true" label="Output name"/>   

             
   </inputs>

   <outputs>
      <data format="sam" name="myTool_outfile" label="myTool on 
${database.value_label}" />
   </outputs>

   <tests>
      <test>
      </test>
   </tests>

   <help>



   </help>

</tool>
</tool>



Regards, 
Marine





________________________________
 De : Hans-Rudolf Hotz <h...@fmi.ch>
À : Marine Rohmer <marine.roh...@yahoo.fr> 
Cc : "galaxy-dev@lists.bx.psu.edu" <galaxy-dev@lists.bx.psu.edu> 
Envoyé le : Mercredi 30 mai 2012 11h42
Objet : Re: [galaxy-dev] Error executing tool: cannot find 'database'
 
Hi Marine

Could you please provide the tool definition xml file. Otherwise it is 
going to be difficult to guess, what is going wrong

Regards, Hans


On 05/30/2012 11:10 AM, Marine Rohmer wrote:
> Hi everyone,
>
> I'm trying with all my best to add an NGS tool into my local Galaxy
> instance.
> I've added my tool in tool_conf.xml, and made a XML file with all the
> <command>, <param> etc... I think it's pretty ok, and everything is
> correctly displayed on the Galaxy interface.
>
> However, when I execute my tool, Galaxy says to me :
>
> Error executing tool: cannot find 'database'
>
>
> And in my shell, I can see :
>
> 127.0.0.1 - - [30/May/2012:10:47:01 +0200] "GET
> /tool_runner?tool_id=myTool HTTP/1.1" 200 -
> "http://localhost:8080/root/tool_menu"; "Mozilla/5.0 (X11; Ubuntu; Linux
> x86_64; rv:12.0) Gecko/20100101 Firefox/12.0"
> galaxy.tools ERROR 2012-05-30 10:47:07,424 Exception caught while
> attempting tool execution:
> Traceback (most recent call last):
> File "/home/myName/work/galaxy-dist/lib/galaxy/tools/__init__.py", line
> 1345, in handle_input
> _, out_data = self.execute( trans, incoming=params, history=history )
> File "/home/myName/work/galaxy-dist/lib/galaxy/tools/__init__.py", line
> 1661, in execute
> return self.tool_action.execute( self, trans, incoming=incoming,
> set_output_hid=set_output_hid, history=history, **kwargs )
> File
> "/home/myName/work/galaxy-dist/lib/galaxy/tools/actions/__init__.py",
> line 333, in execute
> data.name = fill_template( output.label, context=params )
> File "/home/myName/work/galaxy-dist/lib/galaxy/util/template.py", line
> 9, in fill_template
> return str( Template( source=template_text, searchList=[context] ) )
> File
> "/home/myName/work/galaxy-dist/eggs/Cheetah-2.2.2-py2.7-linux-x86_64-ucs4.egg/Cheetah/Template.py",
> line 1004, in __str__
> return getattr(self, mainMethName)()
> File "DynamicallyCompiledCheetahTemplate.py", line 83, in respond
> NotFound: cannot find 'database'
> 127.0.0.1 - - [30/May/2012:10:47:07 +0200] "POST /tool_runner/index
> HTTP/1.1" 200 - "http://localhost:8080/tool_runner?tool_id=myTool";
> "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101
> Firefox/12.0"
>
> I'm a beginner in computer sciences, so I can't understand since over 1
> week what's happening ... Any idea what's wrong with this ?
> (I'm using Ubuntu LTS 12.04)
>
> All help will be very very appreciated !
>
> Thank you,
>
> Marine
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>    http://lists.bx.psu.edu/





________________________________
 De : Hans-Rudolf Hotz <h...@fmi.ch>
À : Marine Rohmer <marine.roh...@yahoo.fr> 
Cc : "galaxy-dev@lists.bx.psu.edu" <galaxy-dev@lists.bx.psu.edu> 
Envoyé le : Mercredi 30 mai 2012 11h42
Objet : Re: [galaxy-dev] Error executing tool: cannot find 'database'
 
Hi Marine

Could you please provide the tool definition xml file. Otherwise it is 
going to be difficult to guess, what is going wrong

Regards, Hans


On 05/30/2012 11:10 AM, Marine Rohmer wrote:
> Hi everyone,
>
> I'm trying with all my best to add an NGS tool into my local Galaxy
> instance.
> I've added my tool in tool_conf.xml, and made a XML file with all the
> <command>, <param> etc... I think it's pretty ok, and everything is
> correctly displayed on the Galaxy interface.
>
> However, when I execute my tool, Galaxy says to me :
>
> Error executing tool: cannot find 'database'
>
>
> And in my shell, I can see :
>
> 127.0.0.1 - - [30/May/2012:10:47:01 +0200] "GET
> /tool_runner?tool_id=myTool HTTP/1.1" 200 -
> "http://localhost:8080/root/tool_menu"; "Mozilla/5.0 (X11; Ubuntu; Linux
> x86_64; rv:12.0) Gecko/20100101 Firefox/12.0"
> galaxy.tools ERROR 2012-05-30 10:47:07,424 Exception caught while
> attempting tool execution:
> Traceback (most recent call last):
> File "/home/myName/work/galaxy-dist/lib/galaxy/tools/__init__.py", line
> 1345, in handle_input
> _, out_data = self.execute( trans, incoming=params, history=history )
> File "/home/myName/work/galaxy-dist/lib/galaxy/tools/__init__.py", line
> 1661, in execute
> return self.tool_action.execute( self, trans, incoming=incoming,
> set_output_hid=set_output_hid, history=history, **kwargs )
> File
> "/home/myName/work/galaxy-dist/lib/galaxy/tools/actions/__init__.py",
> line 333, in execute
> data.name = fill_template( output.label, context=params )
> File "/home/myName/work/galaxy-dist/lib/galaxy/util/template.py", line
> 9, in fill_template
> return str( Template( source=template_text, searchList=[context] ) )
> File
> "/home/myName/work/galaxy-dist/eggs/Cheetah-2.2.2-py2.7-linux-x86_64-ucs4.egg/Cheetah/Template.py",
> line 1004, in __str__
> return getattr(self, mainMethName)()
> File "DynamicallyCompiledCheetahTemplate.py", line 83, in respond
> NotFound: cannot find 'database'
> 127.0.0.1 - - [30/May/2012:10:47:07 +0200] "POST /tool_runner/index
> HTTP/1.1" 200 - "http://localhost:8080/tool_runner?tool_id=myTool";
> "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101
> Firefox/12.0"
>
> I'm a beginner in computer sciences, so I can't understand since over 1
> week what's happening ... Any idea what's wrong with this ?
> (I'm using Ubuntu LTS 12.04)
>
> All help will be very very appreciated !
>
> Thank you,
>
> Marine
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>    http://lists.bx.psu.edu/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to