Hi Greg,

I guess something went wrong while update, because I updated to the 
latest changeset:

hg tip | grep changeset
changeset:   7262:4fbd05095ca7

Can it be because I the last time I updated was at least half a year ago 
and the toolshed integration has been implemented afterwards? So that I 
need to configure the toolshed before I can install something form the 
public one?

Thanks!

Mattias


On 06/13/2012 05:43 PM, Greg Von Kuster wrote:
> Hello Mattias,
>
> Did you pull from the Galaxy central repo?  The latest change set is 
> 7262:4fbd05095ca7, which is what you should be running in order to use the 
> tool shed.  Let me know if you in fact have the latest from central - your 
> line numbers in your log below look to be different from mine.
>
> Thanks,
>
> Greg Von Kuster
>
> On Jun 13, 2012, at 11:38 AM, Hollander, Mattias de wrote:
>
>> Hi,
>>
>> I just updated my local Galaxy installation to the latest version. I am
>> trying out the feature to add tools directly from the toolshed, but this
>> is not working. It results in this error:
>>
>> File 
>> '/usr/local/lib/python2.7/dist-packages/Paste-1.7.5.1-py2.7.egg/paste/exceptions/errormiddleware.py',
>>  line 144 in __call__
>>    app_iter = self.application(environ, sr_checker)
>> File 
>> '/usr/local/lib/python2.7/dist-packages/Paste-1.7.5.1-py2.7.egg/paste/debug/prints.py',
>>  line 106 in __call__
>>    environ, self.app)
>> File 
>> '/usr/local/lib/python2.7/dist-packages/Paste-1.7.5.1-py2.7.egg/paste/wsgilib.py',
>>  line 543 in intercept_output
>>    app_iter = application(environ, replacement_start_response)
>> File 
>> '/usr/local/lib/python2.7/dist-packages/Paste-1.7.5.1-py2.7.egg/paste/recursive.py',
>>  line 84 in __call__
>>    return self.application(environ, start_response)
>> File 
>> '/usr/local/lib/python2.7/dist-packages/Paste-1.7.5.1-py2.7.egg/paste/httpexceptions.py',
>>  line 633 in __call__
>>    return self.application(environ, start_response)
>> File '/home/galaxyTools/galaxy-central/lib/galaxy/web/framework/base.py', 
>> line 160 in __call__
>>    body = method( trans, **kwargs )
>> File 
>> '/home/galaxyTools/galaxy-central/lib/galaxy/web/framework/__init__.py', 
>> line 184 in decorator
>>    return func( self, trans, *args, **kwargs )
>> File 
>> '/home/galaxyTools/galaxy-central/lib/galaxy/web/controllers/admin_toolshed.py',
>>  line 481 in install_repository
>>    install_tool_dependencies=install_tool_dependencies )
>> File '/home/galaxyTools/galaxy-central/lib/galaxy/util/shed_util.py', line 
>> 1228 in load_repository_contents
>>    dist_to_shed=False )
>> File '/home/galaxyTools/galaxy-central/lib/galaxy/util/shed_util.py', line 
>> 342 in create_or_update_tool_shed_repository
>>    installed_changeset_revision=changeset_revision,
>> NameError: global name 'changeset_revision' is not defined
>>
>>
>>
>> And my shed_tools_conf.xml looks like this:
>>
>> <?xml version="1.0"?>
>> <toolbox tool_path="../shed_tools">
>> </toolbox>
>>
>>
>> Should I put more configuration in this file?
>>
>> Any help is appreciated.
>>
>> Thanks!
>>
>> Mattias
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>
>>   http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to