Hi,
  I actually fixed it. I changed the wrapper in the line 105 from:
   cmd_index = 'bowtie-build %s -f %s %s' % ( space, options.own_file,
index_path )

to
   cmd_index = 'bowtie2-build %s -f %s %s' % ( space, options.own_file,
index_path )

Luciano





On Tue, Jun 19, 2012 at 3:03 PM, Luciano Cosme <cosme.sim...@gmail.com>wrote:

>
> Hi,
>    I installed bowtie2 and when running tophat I get the following error:
>
> Error in tophat:
>
> [2012-06-19 14:02:39] Beginning TopHat run (v2.0.3)
> -----------------------------------------------
> [2012-06-19 14:02:39] Checking for Bowtie
>                 Bowtie version:        2.0.0.6
> [2012-06-19 14:02:39] Checking for Samtools
>               Samtools version:        0.1.18.0
> [2012-06-19 14:02:39] Checking for Bowtie index files
> Error: Could not find Bowtie 2 index files 
> (/tmp/tmpojo7bV/AgamP3.14.dna.toplevel.*.bt2)
>
>
>
> I was wondering if I can create the index files using bowtie2 via command
> line and then change the universe_wsgi.ini to:
>  # Temporary files are stored in this directory.
>     new_file_path = database/tmp
>
>
> and put the index files there. Anyway, why is it not creating the indexes?
> I created links to all bowtie2 executable files. If I remove bowtie 0.12.8,
> then I get a error from tophat (bowtie not installed). Is it creating the
> index with bowtie 0.12.8?
> Thank you.
>
> Luciano
>



-- 
*Luciano Cosme*

---------------------------------------------
PhD Candidate
Texas A&M Entomology
Vector Biology Research Group
www.lcosme.com
979 845 1885
co...@tamu.edu
---------------------------------------------
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to