Hi all,

This is going to be a very long message, so please bear with me. Anyway...

I have been asked by my colleagues to integrate modified versions of
velveth, velvetg and oases into our Galaxy instance. Of course, the first
step was to upload the would-be input files. Since these are stored as .dat
files in the database/files/000 folder, I symlinked the uploads to another
folder. When I run the commands of the aforementioned steps, they access
these symlinked files and perform the needed operations using them. I then
just copy the data from the generated files onto the output files that
would be visible in Galaxy. Is everything still clear? I hope so. Moving

Now, they have asked me to integrate another script, and this time it is
running rsem. It requires corrected left and right reads, and OASES'
transcript output. But when I ran the rsem, I got an error concerning the
input transcript file. I found two probable reasons why I was getting an
error. One was that the transcript file might be empty. I've already
checked this, and the file was not empty. Another reason was that the
transcript FASTA file might not be following the required format. And so we
arrive at my question:

Do input and output files go through some minor format modifications when
used in Galaxy?

I have already manually ran the above commands, and everything works well.
But when I downloaded the transcript file from Galaxy to use it via the
konsole, I got the same error.

Thank you in advance for any help,

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to