Hi Geoff,

I encountered the same issue configuring proftpd - thanks for mentioning this issue. Would you mind sharing how you exactly solved the issue with the uid/gid of the galaxy user? I want not to change the uid/gid of this user as it is the same on other machines here.


Joachim


------------------------------

Message: 1223
Date: Wed, 9 Feb 2011 11:31:56 -0800 (PST)
From: Geoff Jentry<geoffjen...@hexdump.org>
To:galaxy-...@bx.psu.edu
Subject: Re: [galaxy-dev] Configuring a ProFTPd server for Galaxy
Message-ID:
        <pine.lnx.4.64.1102091130490.18...@cardinals.dreamhost.com>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed


Oops, please disregard.  As luck would have it, the moment I throw in the
towel the answer becomes obvious to me.  The uid/gid for my galaxy user
was below 999 and getting bumped up to 65535 by the SQL authentication, so
the user FTP directory was getting that uid/gid, was not writeable and
it'd bomb out.  Works now.

On Wed, 9 Feb 2011, Geoff Jentry wrote:

This is probably more appropriate for the proftpd list at this point, but my
thought is that maybe someone has come across this while configuring a
proftpd server for galaxy usage.  I'm including my current output when I try
to log on, a copy of my conf file, and output from the SQL log (in all three
cases, with identifying info removed - users, hosts, IPs, etc).

You can see from the SQL Log that it appears the log in is actually
successful, but then the connection simply closes the connection.  Any ideas
as to what I've got configured incorrectly here?



--
Joachim Jacob, PhD

Rijvisschestraat 120, 9052 Zwijnaarde
Tel: +32 9 244.66.34
Bioinformatics Training and Services (BITS)
http://www.bits.vib.be
@bitsatvib

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to