Dear Galaxy community,

I have a problem with uploading data on Galaxy, using the get data/upload file 
tool, and I can't figure out where the trouble comes from. 

Basically, when I try to upload files (size ranging from less than 1 Mo up to 
600 Mo), sometimes it works, sometimes it doesn't (keep uploading forever), and 
I don't get any error message when it doesn't work. I can't find a pattern on 
when it works or not, it seems pretty random. It don't think it is related to 
the files I use, because I tried with different files, of different types and 
format, and the exact same file can sometimes be uploaded, sometimes not. One 
thing I have noticed is that when the upload is successful, a file is created 
in /tmp/, and when the upload runs forever, no new file appears in /tmp/. 

I have tried a couple of basic things to solve the problem: emptying the /tmp/, 
restarting galaxy, deleting permanently my history, etc. Sometimes I can upload 
4-5 files in a row, then it stops working, and some other time I can't even 
upload one. When one upload keep running forever, even if I cancel it, no 
further uploads will work. I have to stop the uploads and restart galaxy, but 
it doesn't work 100% of the time (sometimes I have to try 2-3 times before I 
can upload again). 

I am facing this problem on two different instances of galaxy. A development 
one that I simply installed on my /home/ using mercurial and didn't modified at 
all, and a production one that I just set up following the Galaxy Team 
recommendations (using PostgreSQL and nginx with the upload module, and working 
on a dedicated Galaxy user account). I am a beginner in informatics, and since 
I get no error message, I don't know where to look for a way to solve this 
annoying problem. 

Uploading files using data libraries under the admin menu seems to be working 
perfectly all the time. 

Thank you very much for your help and advice.

Sincerely

David Roquis
Ph.D. student
University of Perpignan


additional info:
- I am using the latest version of galaxy, and my OS is Fedora 16
- I tried working with and without virtualenv (made no difference).
- I don't know if this is related or not, but it seems quite strange to me. 
Whenever I try to access "manage jobs" in the admin section (on both 
instances), I get the following error message: "This Galaxy instance is not the 
job manager.  If using multiple servers,
 please directly access the job manager instance to manage jobs." How is that 
possible since I am not using multiple servers (especially for the development 
instance, which I haven't modified at all)?
- debug = False is causing me a server error in the history frame (so I use 
True instead). 
                                          
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to