Hi David,

If using the actual tool id (guid) does not work, then it's likely that the job 
runner code needs to be fixed to correctly handle tools installed from a tool 
shed.  I've created a ticket to get this resolved which you can follow so that 
you'll receive status changes on the issue.

https://bitbucket.org/galaxy/galaxy-central/issue/779/fix-job-runner-to-handle-tools-installed

Thanks for reporting this, and sorry for the inconvenience.

Greg Von Kuster

On Jul 21, 2012, at 8:29 AM, <hoove...@helix.nih.gov> wrote:

> I found the guid for the tool and tried the usual method of configuring
> galaxy to use it via drmaa.  With your example, it would be
> 
> toolshed.g2.bx.psu.edu/repos/devteam/freebayes/freebayes/0.0.2 =
> drmaa://-l nodes=1/
> 
> But this didn't have any effect.  It still ran on the localhost.  I guess
> no one has tried this.
> 
> I haven't tried using the old_id.  Would that work?
> 
> I'd rather not run everything via drmaa, but if the toolshed tools can't
> be configured, I might have to.
> 
> David
> 
>> Hi David,
>> 
>> I'm not familiar enough with the job runners to know what the problem may
>> be,  However, for tools installed from the tool shed, the tool id is the
>> tool-shed generated "guid" instead of the "id" attribute value of the tool
>> config's <tool> tag.  So, for example, if you install the freebayes tool
>> shed repository from the main Galaxy tool shed, your tool panel will
>> display the single freebayes tool, which is the only tool contained in the
>> freebayes repository.
>> 
>> When this installed tool is loaded into Galaxy, the tools "id" attribute
>> value is:
>> 
>> toolshed.g2.bx.psu.edu/repos/devteam/freebayes/freebayes/0.0.2
>> 
>> and the tool's "old_id" attribute value is the value os the "id" attribute
>> in it's tool config <tool> tag:
>> 
>> freebayes
>> 
>> Have your tried configuring the installed tool using the new id (guid)
>> rather than the old id?  I'm not sure if this works, but just wanted to
>> make sure you were using the correct id value.  If it still doesn't work,
>> let us know and we'll get a fix asap.
>> 
>> Thanks!
>> 
>> Greg Von Kuster
>> 
>> On Jul 20, 2012, at 5:16 PM, David Hoover wrote:
>> 
>>> Is there a way to configure a tool downloaded from the toolshed depot to
>>> use a job runner other than the local runner?  The tool_id for the
>>> toolshed tool isn't honored in universe_wsgi.ini the way the default
>>> tools are.  Specifically, has anyone configured a toolshed tool to use
>>> drmaa instead of localhost?
>>> 
>>> David Hoover
>>> Helix Systems Staff
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>> 
>>> http://lists.bx.psu.edu/
>> 
>> 
> 
> 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to