Hi all,

We just upgraded our local galaxy to the latest version and now I am
trying to get automatic tool installation to work properly.  I changed
the universe_wsgi.ini file to enable the toolshed xml file, I created
a "shed_tools" directory one above the galaxy install, and restarted
galaxy.  But when I try to install a repository, I get this error as a
popup: "Initializing repository installation failed".  I tried this
with various repositories, but I get the same error.  Then when I go
to "Manage installed tool shed repositories", all of the repositories
I tried to install are stuck in the "Cloning" state.  Finally, if I
try to uninstall any of them, I get this error, with a traceback:

AttributeError: 'NoneType' object has no attribute 'startswith'

Any ideas?

- Nik.

Nikhil Joshi
Bioinformatics Analyst/Programmer
UC Davis Bioinformatics Core
najoshi -at- ucdavis -dot- edu
530.752.2698 (w)
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to