Hi, Dear all,

I am trying to integrate a perl script to GALAXY, and here are the problems.

I have a tool configuration xml file called abc.xml located at
tools/myTools directory, which calls a perl scripts called
toolExample.pl.
  1 <tool id="abc" name="abc">
   2   <command interpreter="perl">toolExample.pl $input $output</command>
   3   <inputs>
   4.......
   5......

Inside the toolExample.pl, I am using some linux system command such
as "wc" and also "BEDTools/windowBed". The BEDTools executables are
configured correctly in my local linux machine, and when I type "which
windowBed" it can give me back the path correctly. When I run
toolExample.pl outside galaxy in the terminal, everything looks
correct; but when I run galaxy, it gave me the nonsense results ( all
0) and it seems that GALAXY has problems in recognizing either the
windowBed excutable file or the linux system command "wc" or maybe
both.

To let GALAXY recognize "windowBed", I tried to put the windowBed
executable copied to myTools directory and add the following
<requirements>tags to the abc.xml file, but it doesn't seem to be
working.
.....
<requirements>
<requirement type="binary">windowBed</requirement>
</requirements>
....

Could anyone please help me figure out what was wrong? How can I fix
the problem? Thank you very much in advance!

Best,
Jenny
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to