Recently, I tried to run galaxy on our cluster and got the following error
messages when I was trying to run samtools.
Everything is running well when I run it on a local machine. Once I switch
it to cluster, the conversion could not be successfully executed.
I checked the version of python, they are all v2.6.6 on both head and nodes
Anybody can help me on this issue?

Thanks a lot in advance!

Traceback (most recent call last):
  File "/home/gxu/galaxy_dist/tools/samtools/bam_to_sam.py", line 10, in
    from galaxy import eggs
  File "/home/gxu/galaxy_dist/lib/galaxy/__init__.py", line 5, in <module>
    __import__( "pkg_resources" ).declare_namespace( __name__ )
  File "/home/gxu/galaxy_dist/lib/pkg_resources.py", line 698, in <module>
    class Environment(object):
  File "/home/gxu/galaxy_dist/lib/pkg_resources.py", line 701, in
    def __init__(self, search_path=None, platform=get_supported_platform(),
  File "/home/gxu/galaxy_dist/lib/pkg_resources.py", line 96, in
    plat = get_build_platform(); m = macosVersionString.match(plat)
  File "/home/gxu/galaxy_dist/lib/pkg_resources.py", line 221, in
    from distutils.util import get_platform
ImportError: No module named distutils.util
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to