Hi Lance,

Thank you for finding this issue and a bigger thanks for the patch. We've 
updated FreeBayes in the toolshed with your patch. Please let us know if you 
encounter further issues.


Thanks!

Dan


On Sep 11, 2012, at 5:08 PM, Lance Parsons wrote:

> Today I ran into a new issues with installing a specific version of 
> Freebayes.  It turns out to be an issue with how git deals with submodules, 
> something I'm only just learning about myself.  In order to ensure that 
> FreeBayes is built with the correct versions of all of the various submodules 
> for the desired revision, it seems that two commands are needed:
> 
> git checkout 9608597d12e127c847ae03aa03440ab63992fedf
> git submodule update --recursive
> 
> In the current version of tool_dependencies.xml, there is a git reset --hard 
> 9608597d12e127c847ae03aa03440ab63992fedf which seems to work similarly to the 
> checkout command above, however, it does not put the submodules back at the 
> correct revisions.  That is only now an issue since they were updated only 
> recently.
> 
> I've attached a patch to the tool_dependencies.xml file that should once 
> again allow FreeBayes to be built and installed automatically.  It would be 
> great if you could update the Tool Shed repo.  Thanks.
> 
> -- 
> Lance Parsons - Scientific Programmer
> 134 Carl C. Icahn Laboratory
> Lewis-Sigler Institute for Integrative Genomics
> Princeton University
> 
> <freebayes_build.patch>


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to