I was trying to upload a 43Gb BAM file to Galaxy when I encountered
this problem. Please let me know how to fix it. I am new to galaxy and
I have tried uploading files in other formats and they have worked fine.
I have not configured error reporting from the web page.
I am using galaxy as a local installation.

Traceback (most recent call last):
  File "/Data/galaxy/galaxy-dist/tools/data_source/upload.py", line
384, in <module>
  File "/Data/galaxy/galaxy-dist/tools/data_source/upload.py", line
373, in __main__
    add_file( dataset, registry, json_file, output_path )
  File "/Data/galaxy/galaxy-dist/tools/data_source/upload.py", line
312, in add_file
    if link_data_only == 'copy_files' and
datatype.dataset_content_needs_grooming( output_path ):
  File "/Data/galaxy/galaxy-dist/lib/galaxy/datatypes/binary.py", line
113, in dataset_content_needs_grooming
    version = self._get_samtools_version()
  File "/Data/galaxy/galaxy-dist/lib/galaxy/datatypes/binary.py", line
97, in _get_samtools_version
    output = subprocess.Popen( [ 'samtools' ], stderr=subprocess.PIPE,
stdout=subprocess.PIPE ).communicate()[1]
  File "/Data/galaxy/Python-2.7.1/Lib/subprocess.py", line 672, in __init__
    errread, errwrite)
  File "/Data/galaxy/Python-2.7.1/Lib/subprocess.py", line 1202, in
    raise child_exception
OSError: [Errno 2] No such file or directory
Report this error to the Galaxy Team

The Galaxy team regularly reviews errors that occur in the
application. However, if you would like to provide additional
information (such as what you were trying to do when the error
occurred) and a contact e-mail address, we will be better able to
investigate your problem and get back to you.
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to