Hi Alex

I am in the same situation, updating our galaxy servers to the "Oct 5th" release (changeset: 7824:b5bda7a5c345), and I have encountered the same problem. I guess, there are actually two problems:



First problem - this happens with a fresh install:
==================================================

I can't create a library at all, I get the following error message:

        Error attempting to display contents of library (foo): No
        module named  controllers.library_common.



There have been a few commits on "library_common.py" over the last few days, which might solve this problem.....?



Second problem - this happens after upgrading an existing installation
======================================================================

Like the situation you reported earlier this morning, I get:


        Error attempting to display contents of library (haruhotz):
        name 'UsesFormDefinitions' is not defined.


I manage to track down the problem to the fact that

in the old version, we've had

~/lib/galaxy/web/controllers/


which apparently has been replaced by

~/lib/galaxy/webapps/galaxy/controllers/


if I remove ~/lib/galaxy/web/controllers/


I get a new error:

        Error attempting to display contents of library (haruhotz): No
        module named library_common.


which is very similar to the error you get with a fresh install


Obviously, old stuff (ie ~/lib/galaxy/web/controllers/) is still used after the upgrade.


Sorry, no solution yet, but maybe it helps the developers to track down the problem and help us getting the servers running again.



Regards Hans-Rudolf


On 10/18/2012 10:48 AM, Alexander Graf wrote:
Hi,
yesterday I updated Galaxy to the latest revision and now it is not
possible to access any Data Libraries or to create a new one.
Galaxy shows me a read box with following error message:

*Error attempting to display contents of library
(100326_HWUSI-EAS632R_0002): name 'UsesFormDefinitions' is not defined.*

The log file message is:

/"GET
/galaxy/library_common/browse_library?sort=name&webapp=galaxy&f-description=All&f-name=All&page=1&cntrller=library&show_item_checkboxes=false&async=false&operation=browse&id=9d04ee723dc2cac7
HTTP/1.1" 302 -
"http://x.x.x.x/galaxy/library/browse_libraries?status=error&use_panels=False&message=Error+attempting+to+display+contents+of+library+%100326_HWUSI-EAS632R_0002%29%3A+name+__sq__UsesFormDefinitions__sq__+is+not+defined.";
"Mozilla/5.0 (X11; Linux x86_64) /

Any ideas how to solve this problem or were to start troubleshooting?

Thank you in advance

Alex




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

   http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to