I'm trying to test out the functional testing mechanism by running it
on an existing Galaxy tool.

First I ran
./run_functional_tests.sh -list

which produced a list of tools I can test. I chose 'vcf_annotate' and
tested it as follows:

./run_functional_tests.sh -id vcf_annotate

This produced a lot of output which included an exception trace. The
output was not conclusive as to whether the test ran or was

The output is too long for this mailing list but you can find it here:

I am reluctant to try and excerpt the relevant bits because it's hard
for me to know what is relevant and what is not.

I am running the latest Galaxy (just did hg pull/hg update and migrated).
This is on a Mac OS X 10.7.4 machine with python 2.7.

When I run the same command on a linux machine, it works (though it
took me a while to find the test output; it was buried in a lot of
output that also contained (apparently irrelevant) stack traces).

So perhaps there is something wrong with my configuration.

Hope someone can help me out.

Also had a couple of newbie questions about the functional test framework.
1) Why does it use tool_conf.xml.sample instead of tool_conf.xml? Can
I change it to use tool_conf.xml? This way I do not need to add tools
to two places in order to test them. (Plus the name of
tool_conf.xml.sample indicates that it is just a demo file).
2) run_functional_tests.sh -list lists tools (such as 'upload1') that
do not have functional tests, so cannot (if my understanding is
correct) be tested with this script. Perhaps it would make more sense
not to list these tools?

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to