Thanks Greg,

Very nice to hear they are all fixed now. Will try and verify when they are
released.

Cheers,
D


On Fri, Nov 9, 2012 at 2:10 AM, Greg Von Kuster <g...@bx.psu.edu> wrote:

> Hello Derrick,
>
> Your message discusses 2 separate issues:
>
> 1. When you install your meme_chip repository from the tool shed, the file
> named tool_data_table_conf.xml.sample contained in the repository is copied
> to the ~/tool-data directory in the local Galaxy instance.  This issue has
> been corrected in change set b5ce9451c5d1 which I committed this morning to
> the galaxy-central repository.
>
> 2. When you install your meme_chip repository from the tool shed, the
> entries defined in the file named tool_data_table_conf.xml.sample contained
> in the repository are not entered into the tool_data_table_conf.xml file in
> the local Galaxy instance.  This issue was corrected in change
> set bc5fa254bafc which I committed to the galaxy-central repository
> yesterday.  With this change set, entries for data tables that are defined
> in tool_data_table_conf.xml.sample files included in the tool shed
> repository will be automatically added to a new separate file named
> shed_tool_data_table_conf.xml.  This will ensure that manual edits made to
> the original tool_data_table_conf.xml file will not be munged when Galaxy's
> tool shed repository installation process automatically adds entries into
> the file.
>
> Unfortunately both of these fixes have not made it into the Galaxy release
> that is currently planned for this week, so they will be available in the
> release currently scheduled for 2 weeks from now.
>
> Thanks very much for reporting both of these issues, and sorry for the
> inconvenience they may have caused.
>
> Greg Von Kuster
>
>
> On Nov 7, 2012, at 8:19 PM, Derrick Lin wrote:
>
> It's actually in related to a new galaxy shed tool we developed called
> meme-chip, we uploaded it to the main Tool Shed site.
>
> We provided tool_data_table_conf.xml.sample and xxx.loc.sample  along
> with the tool. After the installation, the loc file has been populated
> automatically, but the entry inside tool_data_table_conf.xml.sample
> didn't get populated.
>
> Although it can be fixed easily by adding entries to the runtime 
> tool_data_table_conf.xml
> manually, it's good to know if it's the right way or we are missing
> something in the shed tool repos.
>
> Cheers,
> D
>
>
> On Thu, Nov 8, 2012 at 10:20 AM, Derrick Lin <klin...@gmail.com> wrote:
>
>> Hi guys,
>>
>> After installing the BWA from the Tools Shed, I find there is a
>> new tool_data_table_conf.xml got created under tool-data directory. The
>> file contains the entries of BWA's loc files.
>>
>> I believe the installed BWA still relies on the tool_data_table_conf.xml
>> under galaxy root dir. Anyone can clarify what the one under tool-data dir
>> is for?
>>
>> Regards,
>> Derrick
>>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>  http://lists.bx.psu.edu/
>
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to