On Wed, Dec 5, 2012 at 10:56 PM, Nate Coraor <n...@bx.psu.edu> wrote:
>
> Hi Thon,
>
> I just committed a fix for this in 75a97c971d36 that will be available in
> our next distribution release.  It will also match from most to least
> specific so you can define all of:
>
> toolshed.g2.bx.psu.edu/repos/devteam/bwa_wrappers/bwa_wrapper/1.2.3 = foo://
> toolshed.g2.bx.psu.edu/repos/devteam/bwa_wrappers/bwa_wrapper = bar://
> bwa_wrapper = baz://
>
> In this example:
>
> - version 1.2.3 of the bwa wrapper installed from the toolshed would use 
> foo://
> - all other versions installed from the toolshed would use bar://
> - any tool with <tool id="bwa_wrapper">, regardless of how it's installed
>   (from the toolshed or directly added to tool_conf.xml) would use baz://
>
> Only the most specific match will be used if there are multiple matches (as 
> in the example).
>
> --nate

Excellent - that looks much easier to work with :)

Thanks,

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to