Hi all,

I could use some help getting DMRAA to run.  We already have a galaxy instance 
with pbs running, but I'd like to connect to Torque using dmraa because we 
eventually intend to port over to a different resource manager.

I've followed these instructions:
http://apps.man.poznan.pl/trac/pbs-drmaa/wiki#Introduction
http://wiki.galaxyproject.org/Admin/Config/Performance/Cluster

Got dmraa installed and exported a path in my shell config: (PREFIX is long so 
I omitted it)
DRMAA_LIBRARY_PATH=PREFIX/drmaa/lib/libdrmaa.so.1.0.12

in my universe_wsgi.ini:
start_job_runners = drmaa
default_cluster_job_runner = drmaa://-q tstgalxy -V/
addValue = drmaa:///

Here's my pbs_drmaa.conf:
wait_thread: 0,
pool_delay: 5,
keep_completed: 60,
user_state_dir: PREFIX/%s/jobs,

I tried something simple like the add value tool.  When I run it, I get the 
following error state:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "en_US",
        LANG = "C"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

The output file is actually correct, Galaxy just thinks there's an error. I get 
2 files in user_state_dir with a job number and .started (empty) and .exitcode 
(0). Sounds like an env issue?  If I run the perl script generated in the .sh 
file, it works fine. Output as expected. If I use local:/// it works fine with 
no error.

I couldn't find any documentation on how to actually link dmraa to torque.  Am 
I missing something major?
Thanks in advance,

Carrie Ganote
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to