Hi Chun-Yuan,
Sorry to see you're running running into so much trouble. The reality of
the situation is that the Update Galaxy button in CloudMan is currently
broken due to the changes in Galaxy that make the updates a rather manual
process. For the past several weeks, the team has been working on sorting
this out and we are getting closer to having that resolved. The upcoming
upgrade will include an update to Galaxy itself, a number of tools, and the
machine image. Also, a change in the architecture of the cloud deployment
will be necessary to accomplish this. Specifically, galaxyTools and
galaxyData volumes (ie, file systems) will be merged into a single file

As far as mi-deployment goes - it has been deprecated at this point in
favor of CloudBioLinux (cloudbiolinux.org). Over the past 6 months or so,
the functionality from mi-deployment has been merged with CBL and is the
preferred way of building images and tools.

As far as getting a volume attached to a specific instance, the AWS console
allows you to attach a volume to an instance at a given device. Then, the
device becomes available on the attached instance. Note that the device ID
may differ from the one you used to attach the device as - this is noted in
the AWS console at the time of attaching a volume so you should look for a
device with that ID.

As far as support goes - unfortunately, we do not have resources to offer
phone support. Instead, you should subscribe and send emails to galaxy-dev
mailing list (http://lists.bx.psu.edu/listinfo/galaxy-dev). I have CC'd
that list now and posting to that list in the future should give the
biggest exposure to the questions you may have.

Hope this helps. Let us know if you have any more questions,

On Tue, Feb 12, 2013 at 9:04 AM, Chun-Yuan Huang <hua...@uwm.edu> wrote:

> Dear Dr. Afgan,
> I am in a lab that focuses on NGS analysis for Zebrafish Bis-seq dataset,
> and is about to use the Bismark tool (http://www.bioinformatics.**
> babraham.ac.uk/projects/**bismark<http://www.bioinformatics.babraham.ac.uk/projects/bismark>)
> for that purpose.  We were very excited to learn that Bismark works in the
> Galaxy project that you are the main author of, and have been trying to
> install Bismark into Galaxy for the past few weeks. We have tried and
> received the following:
> 1. Start up our own instance on Amazon AWS using ami-da58aab3,
> galaxy-cloudman-2011-03-22, and following the instructions from Galaxy Wiki
> to install Bismark manually, including the necessary modifications on the
> files "universe_wsgi.ini", "tool_conf.xml", "tool_data_table_conf.xml".
> However, the installed Bismark kept generating error messages that we could
> not fully resolve.
> 2.  We later noticed that Bismark can be installed from Tool Shed in a
> rather automatic way. But in order to take advantage of that, we need to
> update the galaxy system into more recent version in order to have the
> recent/automatical Tool Shed. Oddly the link in the Cloudman Admin page for
> "Update Galaxy from a provided repository" doesn't work for us.  So we
> tried to update the galaxy manually, then the Bismark from Tool Shed. It
> worked partially, as some tools are functional but not others, including
> the Bismark. We are in the process of configuring individual tools as well
> as Bismark.
> 3. During the frustration, I kept wondering whether there is a more
> systemic and better documented way of upgrading Galaxy and installing its
> tools such as Bismark. Although we may be able to figure out all the
> problems eventually, the time and work spent on it is rather expensive as
> compared to a stand-alone Linux box.
> 4. So in looking out for a more systemic and better documented solution, I
> just came across your site for the mi-deployment (
> https://bitbucket.org/afgane/**mi-deployment<https://bitbucket.org/afgane/mi-deployment>).
>  By reading its overview, it seems this is exactly the solution I have been
> looking for (sorry for my ignorance on this matter, as I should have tried
> it from the beginning).
> I am in the process of trying mi-deployment. But in the meantime, I would
> like to ask a couple of questions:
> 1. Is "mi-deployment" the right track I should be following, or I am still
> in the wrong place for my situation? Are there more detailed instructions
> on doing it? Do you have any other suggestions? I consider myself and my
> group with fair literacy on bioinformatic tools, NGS tools, and how Linux
> system works (but not experts on it).
> 2. Per your instruction on mi-deployment, we have established a
> "CloudBioLinux" Ubuntu 12.04 instance (version dated to December 2012) and
> have set environment variables for both access key and secret access key,
> in addition to using pip to install boto and fabric. We've attempted to
> create an EBS volume and link it to our EC2 instance, but it does not show
> up within the "/dev" directory following a kernel restart. How may we get
> it to display such that we can then mount it with "sudo mount /dev/VOLUME
> /mnt/galaxyTools"?
> 3. Is it possible that I could reach you by phone for more detailed
> discussion?
> Thanks for your great work on Galaxy, and I look forward to hearing from
> you.
> Chun-Yuan
> --
> Chun-Yuan Huang, Ph.D.
> Research Scientist
> Huangc at uwm.edu
> chunyuan.huang at gmail.com
> Laboratory for Public Health Informatics and Genomics
> Lapham 234, Zilber School of Public Health
> University of Wisconsin – Milwaukee
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to