It's really hard to say what's going on with those issues without more
information about the particular version of galaxy (which
unfortunately we'd get from `hg tip`, which won't work on your bio
linux install) or proxy configuration, if any.  I'm also not sure what
the appropriate bio linux update procedure is or how much
customization they've done to galaxy to make all the tools work in
that environment, but what I'd personally try would be to just clone a
fresh galaxy ( and
migrate your configuration files, etc. if you find that it works.
Once you have an actual mercurial repository updates are trivial (just
the `hg pull -u` that you already tried).


On Thu, Feb 14, 2013 at 2:08 PM, David Joly <> wrote:
> I still haven't heard back from the Bio-Linux guys regarding how to update
> Galaxy within Bio-Linux...
> In the meantime, I tried to play with the "Manage data libraries", in order
> to import large datasets. I modified the "library_import_dir" line in the
> universe_wsgi.ini. The first thing I can say is that when you make a mistake
> in the path (e.g. "../../directory" instead of "../../../directory"), Galaxy
> won't start at all! Anyway, even now that I figured that out, "This dataset
> is uploading" stays forever. As a test, I tried to upload small dataset
> using the usual way ("Get Data"), and here too "Dataset is uploading" stays
> forever. If I revert the "library_import_dir" to normal, I can upload via
> "Get Data".
> Is this also an issue related to the Galaxy version I'm using? Or is the
> Galaxy in Bio-Linux screwed up?
> Many thanks,
> DJ
> 2013/2/13 David Joly <>
>> This could be the problem, I just installed BioLinux 7 on my computer with
>> Galaxy running out-of-the-box...
>> However, it looks like they changed a few things, there is no .hg file and
>> no galaxy-dist folder. Can I update outside of mercurial?
>> 2013/2/13 Dannon Baker <>
>>> How old is the galaxy you're running?  To use the main toolshed you'll
>>> need to use a galaxy-dist release from December or later.  After this point
>>> in time the interface was standardized and is backwards compatible.
>>> To update, you should be able to simply navigate to your galaxy-dist
>>> directory, 'hg pull -u', and you'll be off and running.
>>> Also, since this deals with a local install, please do keep replies on
>>> the 'galaxy-dev' list that I transitioned this thread to instead of
>>> galaxy-user.
>>> Thanks!
>>> -Dannon
>>> On Feb 13, 2013, at 6:43 PM, David Joly <> wrote:
>>> > Ok, one more step closer (I thought closing the browser would be enough
>>> > to restart galaxy, but obviously, I had to reboot the computer).
>>> >
>>> > But now it says: ValueError: too many values to unpack
>>> >
>>> >
>>> > 2013/2/13 Dannon Baker <>
>>> > On Feb 13, 2013, at 6:16 PM, David Joly <> wrote:
>>> >
>>> > > Hi!
>>> > >
>>> > > Ok, I know many people had the same issue, but I just can't figure
>>> > > what's going on. I'm quite new about using a local instance of Galaxy 
>>> > > and
>>> > > I'm trying to figure how to install a tool from the tool shed. Reading 
>>> > > the
>>> > > tutorial  (Installing Galaxy tool shed repository tools into a local 
>>> > > Galaxy
>>> > > instance) looked pretty simple, but maybe I missed something.
>>> > >
>>> > > First, I modified the universe_wsgi.ini file by removing the "#"
>>> > > before the tool_config_file and tool_path lines.
>>> >
>>> > This one step should really be all you need to do (any other files get
>>> > created automatically with reasonable defaults if missing) as far as
>>> > configuration goes.  Did you restart your galaxy instance after editing
>>> > universe_wsgi.ini?
>>> >
>>> > -Dannon
>>> >
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

Reply via email to