Hi, Charles,

builds.txt is what tells the Galaxy framework about available genomes.
Various binary index files created from those genomes are separately
managed for specific tools since some folks won't need some application
specific sets of indexes for any given genome - so you need to edit a
different file!

The BWA for illumina tool for example gets BWA index files from
tool-data/bwa_index.loc so that's where the reference to your ecoli.fa and
related BWA index files needs to be added - the format is described in the
comments you'll find when you edit that file. Tabs for delimiters again and
another restart should fix your problem for that tool?






On Wed, Mar 6, 2013 at 11:46 AM, Charles Murphy
<murphy.charl...@gmail.com>wrote:

> Hi,
>
> I' am trying to add built-in reference genomes for my local galaxy
> installation. I know this topic has been covered multiple times: I have
> looked through the discussion threads and the wiki (e.g. NGS Local Setup),
> but I' am still unsuccessful. Previously I have just loaded a reference
> genome through the history, but in the interest of saving time and space
> while I experiment with Galaxy I wish to use the built-in feature.
>
> Here is what I have tried:
>
> 1. Indexed ecoli.fa using bwa and put all files (fasta and index files)
> under /Users/charlesmurphy/Desktop/Research/data/genome/ecoli/bwa/
>
> The directory looks like:
> -rwxrwxrwx@ 1 charlesmurphy  staff  4706043 Mar  5 14:54 ecoli.fa
> -rwxrwxrwx  1 charlesmurphy  staff       12 Mar  5 16:38 ecoli.fa.amb
> -rwxrwxrwx  1 charlesmurphy  staff      111 Mar  5 16:38 ecoli.fa.ann
> -rwxrwxrwx  1 charlesmurphy  staff  4639752 Mar  5 16:38 ecoli.fa.bwt
> -rwxrwxrwx  1 charlesmurphy  staff  1159920 Mar  5 16:38 ecoli.fa.pac
> -rwxrwxrwx  1 charlesmurphy  staff  2319888 Mar  5 16:38 ecoli.fa.sa
>
> 2. Downloaded and installed the bwa wrapper files from the Galaxy main
> toolshed, and put bwa in $PATH.
> 3. Added the following line to the bwa_index.loc (using tabs as the
> delimiter):
> ecoli   ecoli   ecoli
> /Users/charlesmurphy/Desktop/Research/data/genome/ecoli/bwa/ecoli.fa
> 4. Added the following line to builds.txt (using tabs as the delimiter):
> ecoli ecoli
> 5. Restarted Galaxy.
>
> The ecoli genome does not show up as a reference genome for BWA (Map with
> BWA for Illumina). Any help would be appreciated.
>
> Thanks,
> Charlie
>
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to