Thanks Ira,

We'll take a look at this as soon as possible and get back to you.

Greg Von Kuster

On Mar 6, 2013, at 3:45 AM, Ira Cooke wrote:

> Hi Greg, 
> 
> I should probably add to this some background info about my dependencies .. 
> which are a bit weird. 
> 
> Basically I have a bunch of repositories that all depend on a rubygem I 
> wrote.  This gem is installed under its own gemset using rvm.  Installation 
> of this repository is essential before any other repositories can be 
> installed because it contains all the instructions on how to build stuff etc. 
>  As you've seen, I have defined this repo as a dependency of all my 
> repositories .. which works fine .. but when I have a chain of dependencies I 
> have problems.
> 
> (eg Repo omssa -> protk_omssa -> galaxy_protk ) .. I define omssa so that it 
> depends on both galaxy_protk and protk_omssa ... and in repo protk_omssa I 
> tell it that it depends on galaxy_protk.   When I go to do an install of 
> protk_omssa it works fine ... but when I try to install "omssa" without first 
> installing the other dependencies it attempts to install other repos before 
> installing galaxy_protk. 
> 
> I hope that makes sense. 
> 
> As another issue I realise that it might be a bit dodgy to install things 
> under the galaxy users home directory.  I tried to get around this but it's 
> tricky.  RVM for instance doesn't seem to like being installed anywhere other 
> than ~/.rvm .  In the end I also decided to keep my ~/.protk directory in its 
> same position because this allows an admin user to more easily manage 
> centrally installed databases (that should be in ~/.protk/Databases ).   I 
> have taken some care about encapsulating dependencies for different tool 
> versions though.  This is done by installing the protk rubygem into a gemset 
> that is labelled according to the protk version.  I also install all other 
> protk related tools into the normal galaxy tool directories ... and protk 
> knows where these are by virtue of setting environment variables (eg 
> PROTK_TPP_DIR) in the relevant env.sh scripts.
> 
> Anyway I'm reasonably happy with the dependency system .. it would be nice to 
> get the issue with chained dependencies worked out though.  
> 
> Cheers
> Ira
> 
> 
> On 06/03/2013, at 1:25 AM, Greg Von Kuster <g...@bx.psu.edu> wrote:
> 
>> Hello Ira,
>> 
>> Thanks for all of the work you've been doing n your repositories - I've been 
>> getting email updates from your repository changes.
>> 
>> I'm not quite sure what is causing this behavior.  I've taken a glance at 
>> your many dependency definitions, and they look correct, so I'm not seeing 
>> why certain directory paths are required by some repositories.  Required 
>> paths like this are handled with complex repository dependencies (which you 
>> have correctly defined), so you may have uncovered a corner-case issue that 
>> I didn't encounter during development.
>> 
>> This may take a bit of time to figure out and resolve, but I'll let you know 
>> as soon as we uncover and resolve the problem.
>> 
>> Thanks!
>> 
>> Greg Von Kuster
>> 
>> 
>> On Mar 5, 2013, at 1:49 AM, Ira Cooke wrote:
>> 
>>> Hi, 
>>> 
>>> I've just uploaded a set of updates to my proteomics tools on the toolshed. 
>>>  These contain my best attempt to implement automatic dependency 
>>> installation ... and for the most part it seems to work. 
>>> 
>>> I have encountered the following issues though
>>> 
>>> (1) I don't see any way to ensure that one repository_dependency is 
>>> installed before all others.  In my case this is important because I have 
>>> an installer package (galaxy_protk) which needs to be installed before 
>>> other package installs will work.
>>> 
>>> For example .. try installing
>>> 
>>> http://toolshed.g2.bx.psu.edu/view/iracooke/omssa
>>> 
>>> (2) Running multiple repo installs at once is not reliable (sorry this is 
>>> so vague).  When I have many dependencies being installed at once I get the 
>>> following error (for example)
>>> 
>>> "Could not cd to 
>>> ./database/tmp/tmpbIqBW8/galaxy_protk/./database/tmp/tmp3vhKn6/galaxy_protk"
>>> 
>>> It looks like a path is not being constructed correctly. 
>>> 
>>> If I wait until the currently installed repo is finished .. then try 
>>> uninstalling and reinstalling it works.
>>> Sorry this is vague but if you try installing any of the following 
>>> repositories you should see what I mean
>>> 
>>> http://toolshed.g2.bx.psu.edu/view/iracooke/xtandem
>>> http://toolshed.g2.bx.psu.edu/view/iracooke/msgfplus
>>> http://toolshed.g2.bx.psu.edu/view/iracooke/tpp_prophets
>>> 
>>> Anyway .. and just so it doesn't just sound like I'm complaining ... I 
>>> think the dependency installation stuff is hugely useful.  It took me a 
>>> while to figure out all the details .. but I think it makes sense now.
>>> 
>>> Cheers
>>> Ira
>>> 
>>> _______________________________________________
>>> galaxy-iuc mailing list
>>> galaxy-...@lists.bx.psu.edu
>>> http://lists.bx.psu.edu/listinfo/galaxy-iuc
>> 
> 
> 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to