Hi Galaxy Admin list,

This is my first post to this list.  Galaxy is a great tool and I am really
enjoying working with it.

Background, I am setting up a private galaxy instance for my company using
AWS.  The installation is going very smoothly with a few problems listed
below. I apologize if these questions have been asked before.  I have been
through the documentation and searched the list pretty thoroughly and can't
find the answers.  Thanks in advance for your help.

Question 1: Can't install tools in the tool shed

I have added this line to the universe_wsgi.ini

tool_config_file = tool_conf.xml,shed_tool_conf.xml

Which references a file that contains this tag:

<toolbox tool_path="../shed_tools">
</toolbox>

I have created this directory at the correct level and set permission to
755.

But I am still getting a non specific error loading tools.
I saw that this was (is?) a known issue, but that it had been resolved in
the latest build. What am I missing?
The log does not give me any more specific information about the error.

Any suggestions?

Question 2:  Weird log error.
 Every minute the log records this error:
galaxy.web.framework DEBUG 2013-03-07 13:07:42,207 Error: this request
returned None from get_history(): http://127.0.0.1:8080/root
127.0.0.1 - - [07/Mar/2013:13:07:42 +0000] "GET /root HTTP/1.1" 200 - "-"
"Python-urllib/2.6"
Is this a known issue?  How can I find more information about what is
causing it?

Question 3:  Correct Settings:  My intent is to allow employees to access
galaxy remotely without allowing public access.  In order to keep the data
private, I have set:

require_login = True
allow_user_creation = False

Other than the id_secret setting (which I am currently researching) are
there any big security holes I am missing with the default installation?

Thanks again for the help.

Adam


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to