The following is the stack trace I got when I applied the patch and clicked the bug icon.

"GET /dataset/errors?id=c39bc73d0eae67dd HTTP/1.0" 500 - "http://galaxy/history"
Error - <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'hid'
URL: http://galaxy/dataset/errors?id=c39bc73d0eae67dd
File '/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/exceptions/errormiddleware.py', line 143 in __call_ _
  app_iter = self.application(environ, start_response)
File '/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/recursive.py', line 80 in __call__
  return self.application(environ, start_response)
File '/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/httpexceptions.py', line 632 in __call__
  return self.application(environ, start_response)
File '/galaxy-dist/lib/galaxy/web/framework/base.py', line 132 in __call__
  return self.handle_request( environ, start_response )
File '/galaxy-dist/lib/galaxy/web/framework/base.py', line 185 in handle_request
  body = method( trans, **kwargs )
File '/galaxy-dist/lib/galaxy/webapps/galaxy/controllers/dataset.py', line 175 in errors
  return trans.fill_template( "dataset/errors.mako", hda=hda )
File '/galaxy-dist/lib/galaxy/web/framework/__init__.py', line 848 in fill_template
  return self.fill_template_mako( filename, **kwargs )
File '/galaxy-dist/lib/galaxy/web/framework/__init__.py', line 859 in fill_template_mako
  return template.render( **data )
File '/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/template.py', line 296 in render
  return runtime._render(self, self.callable_, args, data)
File '/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/runtime.py', line 660 in _render
  **_kwargs_for_callable(callable_, data))
File '/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/runtime.py', line 692 in _render_context
  _exec _template(inherit, lclcontext, args=args, kwargs=kwargs)
File '/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/runtime.py', line 718 in _exec_template
  callable_(context, *args, **kwargs)
File '/galaxy-dist/database/compiled_templates/dataset/errors.mako.py', line 27 in render_body
  __M_writer(unicode(hda.hid))
AttributeError: 'NoneType' object has no attribute 'hid'

-----Carl Eberhard <carlfeberh...@gmail.com> wrote: -----
To: Eric Enns <eric.e...@phac-aspc.gc.ca>
From: Carl Eberhard <carlfeberh...@gmail.com>
Date: 03/12/2013 09:47AM
Cc: "galaxy-...@bx.psu.edu" <galaxy-...@bx.psu.edu>, Jean-Francois Payotte <jean-francois.payo...@dnalandmarks.ca>
Subject: Re: [galaxy-dev] Error Report contains STDERR from different job

Can you post the stack trace from the error, please?

Thanks for the info,
Carl


On Tue, Mar 12, 2013 at 10:37 AM, Eric Enns <eric.e...@phac-aspc.gc.ca> wrote:
Hey,

I applied the patch and it does not help, instead I received a server error since hda was none. If it helps at all I am using mysql as my backend.

-Eric

-----Carl Eberhard <carlfeberh...@gmail.com> wrote: -----
To: Jean-Francois Payotte <jean-francois.payo...@dnalandmarks.ca>
From: Carl Eberhard <carlfeberh...@gmail.com>
Date: 03/08/2013 05:10PM
Cc: eric.e...@phac-aspc.gc.ca, "galaxy-...@bx.psu.edu" <galaxy-...@bx.psu.edu>
Subject: Re: [galaxy-dev] Error Report contains STDERR from different job


Hello, 
Does applying the patch from "[galaxy-dev] Strange issue where the dataset reported in the bug report doesn't correspond to the current dataset" help?

If not, we can diagnose further. Thanks,
Carl



On Fri, Mar 8, 2013 at 3:35 PM, Jean-Francois Payotte <jean-francois.payo...@dnalandmarks.ca> wrote:
Dear Eric,

I'm glad to know that I am not the only one having this bug. (Even though I would prefer if neither of us would have it). ;)

I've already written twice to the galaxy mailing-list, but I didn't receive any answers so far.
Let's hope someone will be able to help us solve this issue.

You can see my mail thread here: http://dev.list.galaxyproject.org/Strange-issue-where-the-dataset-reported-in-the-bug-report-doesn-t-correspond-to-the-current-dataset-td4658707.html

Best regards,

Jean-Francois




From:        Eric Enns <eric.e...@phac-aspc.gc.ca>
To:        galaxy-...@bx.psu.edu
Date:        08/03/2013 03:14 PM
Subject:        [galaxy-dev] Error Report contains STDERR from different job
Sent by:        galaxy-dev-boun...@lists.bx.psu.edu




Hey,

When clicking the "View or report this error button" the error message shown occasionally is from a different job. If you go into the info for the job you can select stderr and see the correct error. If the user submits the error to admins they receive the wrong error message and a link to the wrong history.

-Eric
___________________________ _________________ _______ ________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 
http://lists.bx.psu.edu/

____ _________________________ ________ _________________ _____
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to