Hello Lance,

Sorry this didn't work.  I've opened the following Trello card for this issue.

https://trello.com/card/toolshed-handle-images-defined-in-help-sections-of-tool-configs-contained-in-a-repository/506338ce32ae458f6d15e4b3/725

Thanks,

Greg Von Kuster


On Mar 22, 2013, at 1:50 PM, Lance Parsons wrote:

> Thanks for the quick response Greg.  I tried this and uploaded an update to 
> the testtoolshed and installed that in a test instance of Galaxy.  
> Unfortunately, it didn't seem to resolve the issue.  Galaxy still renders the 
> html with the image source pointing to the same location (e.g. 
> http://127.0.0.1:8080/static/images/count_modes.png).  This doesn't resolve.
> 
> You can try installing the htseq_count package from the testtoolshed to see 
> the issue for yourself. 
> 
> Lance
> 
> Greg Von Kuster wrote:
>> 
>> Hi Lance,
>> 
>> I answered this in your previous email - here's the answer:
>> 
>> To make this work in the tool shed, make the static directory that contains 
>> the image file a relative path in the tool config.  For example, your 
>> repository has the following structure:
>> 
>> htseq_count
>> htseq-count.xml
>> sam_fa_indices.loc.sample
>> static/
>>      images/
>>              count_modes.png
>> test-data/
>>      tool_data_table_conf.xml.sample
>>      tool_dependencies.xml
>> 
>> 
>> The help section of your tool config should simply use a relative path to 
>> the image file ( in this case, just a a "." in front of the path to the 
>> image file )
>> 
>> .. image:: ./static/images/count_modes.png
>>     :width: 500
>> 
>> I believe that's all that is necessary.
>> 
>> Greg Von Kuster
>> 
>> 
>> On Mar 22, 2013, at 12:44 PM, Lance Parsons wrote:
>> 
>>> For one of my tool wrappers (htseq-count) in the toolshed, I point to an 
>>> image file in the Help section.  At the moment, I'm including the image in 
>>> the repository as static/imagescount_modes.png and pointing to it in the 
>>> wrapper.xml file with ".. image:: /static/images/count_modes.png".  
>>> However, the toolshed installation doesn't copy this file to the static 
>>> directory of the galaxy install (which doesn't seem like a good idea 
>>> anyway).  Is there any way for me to include a static file and then point 
>>> to that file in the help when the tool is installed automatically via the 
>>> toolshed.. Thanks.
>>> 
>>> -- 
>>> Lance Parsons - Scientific Programmer
>>> 134 Carl C. Icahn Laboratory
>>> Lewis-Sigler Institute for Integrative Genomics
>>> Princeton University
>>> 
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>> http://lists.bx.psu.edu/
>>> 
>>> To search Galaxy mailing lists use the unified search at:
>>> http://galaxyproject.org/search/mailinglists/
>> 
> 
> -- 
> Lance Parsons - Scientific Programmer
> 134 Carl C. Icahn Laboratory
> Lewis-Sigler Institute for Integrative Genomics
> Princeton University
> 

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to